Wavelab Cast Rendering mp3 with wrong track length data

Version 1.3.0 (build 13) - x64

So I’m not sure what I’m doing wrong exactly, but for any mp3 file I output, any player that I use reports the wrong track length. The track plays correctly, but this is wild… some apps double the song length and when testing by sending tracks in apps like discord or FB messenger, the length reports as 6:30 for example for a 4:25 track.

While I do have a background in software engineering I can’t seem to uncover a setting anywhere that suggests what I might be doing wrong.

I’m totally lost at the moment. Anyone else ever bump into this?

A mp3 file does not have, by default, a header that specifies its length.
However, if the encoding is CBR, this is easy for the player to compute this length.
But if VBR encoding is used, then finding the length for the player is a big approximation… unless
• this following option is set in WaveLab
• the player supports this non-mandatory VBR header.



What kind of encoding Lame or Fraunhofer
kind of settings for sampel rate and bitrate e.t.c ?

regards S-EH

So that setting for me is checked and greyed out by default:


It seems switching from LAME and using Fraunhofer resolves the issue.

That said, does LAME always respond like that? Or is there a way to make it work?


I think PG made a very clear answer how it works in WaveLab
and Fraunhofer or Lame does it matter ?

regards S-EH

1 Like

It appears to, when I pick LAME, the boxes are already checked yet the problem still exists. However simply switching to Fraunhofer allows it to work as expected. Good for now as it solves the problem, but it means I can’t use LAME to render VBR if I want the track lengths to report correctly.

It appears that either there’s another setting that conflicts with the LAME configuration OR perhaps that setting isn’t getting added to the final output when I select the LAME encoder?