WaveLab Elements 11.1 Upgrade from WaveLab Cast

Hey Guys,
Has anyone encountered an issue when they purchased WaveLab Elements 11.1 Upgrade from WaveLab Cast ?
After I purchased the upgrade I received the download access code and I when went through the install process I’m getting this.

I have a valid license for WaveLab Cast so I’m unsure of the issue. Can anyone help?

1 Like

I didn’t get the same error but I have an issue upgrading my WaveLab Elements 11.1 to WaveLab Pro 11.1. I purchased upgrade for version Elements 7 and higher but I can’t apply it. I already switched from eLicenser to Steinberg Licensing and seems like my purchased upgrade is applicable only to eLicenser licenses.

Which type of license of WaveLab Cast do you have currently and which type of upgrade did you purchase?

Same here. I have just opened a ticket.
It looks like the support folks are currently pretty overloaded; another ticket I had filed 9 days ago has not bee replied to yet…
But good to see I am not the only one having this issue.

@Jonathan_McCormack have you been able to solve your problem? I am still waiting for support to reply to my help request. My temporary product activation will expire in 14 days…

Haven’t solved the issue. Haven’t received a response back from my many tickets or a refund I requested. Shocking support and customer service.

I had eLicenser then switched Steinberg Licensing as upgrade was not valid with eLicenser so I redeem the license to Steinberg Licensing and had to re install wavelab cast because it lost its license. I then tried to redeem the download voucher for wavelab elements and I got the same thing…

1 Like

Thank you for responding. This is really bad news. Let’s keep each other posted here if there is any update in whatever direction.

I have the same problem. Purchased the Upgrade from Elements 11.1 to Pro 11.1 and it gave me an error message. Sweetwater then gave me a different access code which turned out to be an Upgrade for Cast…
They’re still trying to sort it out.

So let’s vote this thread up (I already have), and let’s hope for one of the Steinberg folks to see this and jump in to help?

1 Like

Got this from the support team and it has worked for me now.

“We noticed that the WaveLab Cast update to WaveLab Elements was not configured correctly on our license server. The update did not detect WaveLab Cast OEM as a valid updatable license.

We have fixed the problem and you can now complete the update. Therefore, please re-enter the Download Access Code in the Steinberg Download Assistant to complete the update. The error message shown on your screenshots should not appear again.”

Same here. Things work now!

Mines’s still not working…

I’m having similar problems with WaveLab Elements 10, doesn’t recognise my activation code since I upgraded osx to Monterey. Written 3 times to Steinberg, no response apart from automatic notice of receipt of my email. I find the licencing and activation code instructions extremely difficult to follow, I spend hours going round in circles, going nowhere until I finally give up and turn off my computer! Any advice would be welcome.