Wavelab Pro 10 - Cannot update or remove

I installed and used Wavelab Pro 10 v …30 on W10 65bit last year with no problems since.
However I have just tried to update it to v …60 but it fails with an error.
I’ve tried an earlier update (…40) and new install and have tried removing first but every operation fails with the same error. I seem to be stuck. The existing install still works after Uninstall failed attempt rollback.

Any ideas please?



Try the following script to make a clean uninstall (your preferences will be preserved).
Then do a new install with the Steinberg Download Assistant.
uninstall_wavelab_100.zip (546 Bytes)

Same error with



Looks like maybe something missing in registry?
I did run eLicenser - no effect.
(Download Asst. update failed in my first update attempt)

Thank you so far…

Try to erase this folder completely:

Thank you… any idea which one? Do you know what they are? Are they all Wavelab related or are any common files (dlls)?

Heres the x64 folder content…

(I dont want to break anything else!!)

This folder is created by the installer. Only temporary file. It is safe to remove the whole of it.

1 Like

So this is weird. All deleted but uninstall / Update / Full install still all fail with same note with regards to C:\ProgramData\6BCCA8C5-7E69-4622-BCCA-9FAC488059BD.
Does it expect a key or reference there which is missing? Or is it a folder access issue I wonder?

UPDATE:… Success! There was another folder given related to this and once deleted update tried again to v…40 (whole) then v…60 (update) were successful (or maybe I had the wrong folder…)
Thank you for your help PG1 - with this 100% fixed :grinning: :ok_hand: