WaveLab Pro 11 user presets

I can’t save the presets that I make on some of the plugins including all of Steinberg’s. I am on macOS 10.15.7. Does anyone else have the same problem?

Screen Shot 2021-09-11 at 11.19.18 AM|690x351

Yes! I’ve been battling something like this for years on a handful of machines and WaveLab/MacOS versions. Only with seemingly random plugins.

For sure it’s currently happening with Sonnox but it’s happened with others as well, not just Steinberg plugins.

Please verify that you have write-permission to the folder displayed in the message box.
You could simply open this folder, and copy any file into it. Then you should remove it.

It works, thank you,

Do you mean, the problem is now solved. Or just that you can copy/delete a file to the folder?

I just had to change permission to read and write on the presets folder.

Yes, Problem solved

Thank you,

Ah, after doing some closer looking, I was able to solve my long-time issue. A few folders in this path for a Sonnox plugin seems to have been set to Read-Only.

This raises the question of why WaveLab is trying to save these settings in a locked area. There are two libraries with Audio/Presets folders. One is a system path, one is a user path.

Are we sure WaveLab is using the right one always?

1 Like

WaveLab is saving to a place that is meant to be writable. If it is not, this could be because the installer of the plugin has created a read-only folder for its preset.

Good that you finally found the solution.

Interesting, because this has happened over a few computers/MacOS versions over a few years, and I always do a “clean” MacOS setup when I get a new computer rather than migrating settings.

I’ll have to see why on my end, some of these folders are not correctly set.

I feel like for my username it was set to Read & Write, but I had to change it to “Everyone” for it to work in WaveLab…and my computers only have one main user account.