Wavelab Pro 12 | activated but no valid licence found


I´ve been runnging thru this nightmare installation and activation.

My status is:

  • Wavelab Pro v12 is activated in Activation Manager
  • Programm closes immediately after startup because it does not find the licence.

I tried:

  • Reinstall Wavelab Pro v12
  • Reeboot
  • contact support …seems like there is nobody home

any help here?
thank you,

Make sure you have the latest version of Activation Manager:

Yep, sorry, I can confirm:

  • Activation Manager v1.4.41.1101

Is this PC or OSX … if OSX which version?

I am having the same issue but with Cubase 13. It shows active in the Activation Manager but Cubase 13 won’t load saying "No vadid licence found. Have you had any luck with a fix?

2024-06-15 trying to start Cubase 13

I use OSX14.5 Sonoma in Apple Silicon
I wanted to reply this morning but the forum did not accept my answer, so I try again.

In the meantime I did exacly nothing, buty tried again and again, and now it started. …I don’t know why and how. Feels totaly strange.

I love that the USB Dongles are retired, but I think Steinberg replaced it with a bad activator software. So much perfect working solutions out there and then this. I hope it is stable. And again Steinberg helpdesk seems also know the issues, so waiting is a good chance for them. …no reply jet.

I have not been in such a situation yet, but I guess I would try to deactivate the license in SAM and then activate it again in hope to re-toggle the activation status.

Thank you for the update and happy that it is now working. It will probably be OK now it has ‘found’ the license.

When this new system was introduced there were a number of users reporting similar issues.

In 2024 users should not have to trouble shoot license issues to try and make software that they purchased work.