Waves NLS problem;

I’m demoing Waves NLS and I’m really liking it so far. Despite of its merits, I’m having a problem: should I use it in more than 32 channels, from the 33th on the GUI is blank and I can’t use it, so I’m stuck with 32 channels, which is not enough. Plus adding NLS Buss instances show odd white background and flickering behavior.

I have already contacted Waves support and I’m waiting for an official answer, but I wonder if anyone here has had positive experiences with NLS and high track count.

I feel the problem could be my video card, which is an Intel HD 2000 embedded in i5-2320 CPU, but I can’t understand why the 32 1st instances inserted open fine, whenever they are placed in the project.



Totally derailing your topic, but curious…doesn’t that thing bypass your sends when it goes from an insert on the track to an insert on the master buss? Maybe I’m not understanding it completely, but that would be a deal-breaker for me.

I don’t think I understand your question, but if you have sends that are post-fader, nothing in the track is bypassed. If the send is pre-fader, you might want to insert NLS in the track you’re sending to as well.

To extend my question, has anyone had problems with Intel HD Graphics and waves plugins? You must have a high number of waves plugins in a project to reproduce my problem, in my case, 32 with a i5-2320 and Intel HD 2000 Graphics (embedded).

Hi - not having trouble with NLS, but recently took advantage of the $64 sale and bought rvox to compliment many other waves plug ins. Of course I had to download v9 and since then Cubase hasn’t worked right. I have the distinct feeling it’s my Radeon 4300/4500 conflicting in some way with v9 which until now hasn’t been a problem. Re-installed drivers numerous times and also the settings to no avail. GUI failures when the projects which have heavy use of waves plug ins eventually load (28 mins on average) IF they load. Also, it’s asked to rescan licenses more than once. Despite not being a happy bunny I know it’s no use being angry about it; Waves Tech Support have been very helpful and given various solutions, none of which have worked yet but it’s an ongoing process…which I think will probably result in a roll back to v8 (as I’m using 32 bit Cubase for my projects atm) I imagine which would be annoying as I’m ready, after I complete my current projects, to start using Cubase 6 (aritst) 64 bit with attendant Waves plug ins.

Anyway, any ideas would be welcomed. Cheers.

Waves has replied me that they are aware of the problem with V9, although they were not too specific and my question was focused in high instances count. They said NVidia cards won’t show the symptom, so I guess users of onboard and ATI are in trouble for the moment with V9. Also, they said the problem is with all v9 plugins, not only NLS, so your Radeon might be really conflicting.

Anyway, they said they’re working on it, so I imagine it’s a matter of time, and short time, since it’s no small issue.

i also experience this problem; my machine has a Radeon HD 4350. Also, since Waves V9, my machine seems to be under a lot more stress! Fans seem to rev up more than they used to. i don’t understand. i thought with V9 64bit plugins we could use a lot more instances of the plugs and wouldn’t notice problems, Especially when there is enough RAM installed and you’re using an i7 core machine. Maybe i misuderstand this. Hope Waves gets us help soon. :confused::cry:


Somewhat tangentially, have you noticed that NLS appears under “Distortion”? On other hosts, it appears (more appropriately, I think) under “Harmonics”. The same is true, btw, for Kramer Tape.

It’s a small thing, but I wanted to see if it could be fixed. I contacted both Waves and Steinberg. After a few back and forth emails, it seems no one is keen to fix this. Every time I look for these plugins, I have to pause and say “Oh, right…distortion.”

So much for the details.

It appears under distortion because it IS distortion. I would rather it stay where it is at and do not consider it something that needs to be “fixed”.

It would be nice if they soon fix the actual memory bug that is causing plugins not to show up…

I recently bought NLS buss plugin but can’t see it in my cubase…any clue?