Waves Plugins don't load - possible fix

I could solve following problem:

On Windows 10 (20H1) after one of latest Windows Updates: Neither Cubase 11.0.30 nor Waves Plugins installed from current Waves Central 12.0.20 did anyhow complain. They appeared as if installed properly but when I selected a Waves plugin the slot was cleared after selection.

I found a hint here in the forum to reinstall Microsoft C++ Redistributables 2015-2019. This did not solve my problem.

I tried to install Microsoft C++ Redistributable 2012 (vcredist_x64_2012.exe) from the Waves programm folder c:\Program Files\Waves Central\resources\res\external\Redistributables\2012.

The installer offered me to fix the installation: Bingo - solved my problem after countless hours of investigation. Plugins now load properly as expected.

Perhaps this may help other users.

3 Likes

I created an account here because I needed to thank you. I’ve been repeatedly hitting my head against a wall with this issue for over two weeks and had so little faith left in any solution that I was actually flabbergasted to find one that worked. Thanks so much!

1 Like