Waves plugins not seen by Pro 9

Pro 9 cannot see my waveshell x64 dll
I have tried moving it to different folders and adding them to the Path Settings and rescanning/restarting but the program totally ignores this file. Waves are not in my Blacklist folder either, it simply cannot see the file at all and therefore I have no Waves plugins.
This is very weird as I go back to Cubase Pro8.5.20 and they are all there, no problems, all smooth and load lovely.
Back to Pro 9 and NO WAVES.

Anyone got similar problems, any ideas?
Thanks in advance

Working fine here. Make sure you Install the latest version of Waves Central.

I wouldn’t recommend moving Waves files around.

Yup, same here.

I had the same problem, the problem was having a 32-bit version of the shell .dll that Cubase was finding and that prevents the 64-bit one being looked at.

So make sure the 32-bit shell .dll is not in any folder that Cubase is looking in - just the 64-bit one,
then everything should be OK

Well, have tried removing all 32 bit instances from my system, nothing…removed all waves and re-installed waves central and the plugins, still nothing. I give up!!

You need the VST3 shell. No more vst2.4 support for shells.

That’s true. At first I though my waves stuff was blacklisted but it was just the 2.4 stuff - the vst3 was present and correct.

Ok sorted it eventually, it was to do with the VST 3 so thanks for all your help.

im having this problem as well, can you tell me how you sorted it please?

It is not ideal, but I have had this with Waves plug-ins, and, on the advice of somebody on here, I deleted and then re-installed Waves Central (after fully installing the plug-ins), low and behold I restarted and they were available to use.

that worked for me too

Hey,

After having the same issue, I wanted to share my “solution”.

So, I bought some Waves Plugins, and Cubase was blacklisting them everytime. At first, I thought it was a 32bits version that was not working, but it wasn’t, and even my 64bits were blacklisted.
Then I saw that they were all VST 2 plugs, but after hours of trying to find the solution, I asked Waves to help me.

Here’s their answer :

Uninstall:
Once the license is sent choose: Install->Uninstall Products (at the top).
Choose all the products click ‘Uninstall’.
Once uninstall is finished - quit Central.

Uninstall Central :

Uninstall Waves Central itself using Control Panel->Programs and Features

Remove Various files:
Click on Winkey+R and enter the text %appdata% - click Enter. Delete the Waves folder inside ‘Roaming’.
Click on Winkey+R and enter the text %programdata% - click Enter. Delete the ‘Waves Audio’ folder.
Conduct a file search on your system for the term :“WaveShell” and delete any “WaveShell” file that you find.

Re-Install:

Download and install the latest Waves Central for Windows
Run Waves Central application and log-in.
Click on Install at the top tab, then select Install
Click Online (on left pane)
Select all your products (in the middle pane)
Click Install on (the bottom right)



So, I think that the real thing here is to clean all your system in order to have a real fresh install. Follow every little step + CCleaner if needed.
It worked for me, I hope it’ll for you, people of the future.

Thank you. That worked. I also found that some of the plugins were blacklisted within Cubase after doing all that. All good now.

That’s the solution. Waves also brought the same kind of solution consisting in removing the caches files (https://www.waves.com/support/error-during-product-installation-using-waves-central).

I had to do something very similar to what KurtOzz did. Waves’ tech support got back to me in 10 minutes. My problem was somewhat different. (See this post in another thread). I had plugins show up but some would not load. And the plugin manager would freeze. But it’s working fine after the re-install.

Thanks to all, however I did all the uninstall, deletes & reinstall and problem still exists where C9.5 blacklists the plugins. Any further recommendations ?

None of these methods worked for me.
Pro 9 simply will not pick up the vst3’s (and it just blacklists anything vst2).
After a clean up of old waves and following the re-install methods listed here and at their website i still have no waves plugins that i’ve paid for.
It’s beyond frustrating…

I just want to say that I had exactly the same issue, and was pulling my teeth out! But the solution listed here worked out for me - so a big thanks! I had already tried much of what was suggested in this solution, but it seems that it was deleting the WaveShell stuff that did the trick in the end.

Nice one and thanks once again for posting this!

Johnny

There’s now a version 10 of the waves engine. I upgraded to it, and responded “yes” when waves central asked to delete the V9 stuff. Then I was without Waves plugins. (Not picked up by Cubase Pro 9 Plugin manager) A bit unnerved, I called their tech support, and it turns out you have to go and update your V9 licenses to V10. Things went well after that.

This sort of issue may be coming up for others at this time.

I had a similar issue. After contacting Waves they told me I needed to us the offline installer option through Waves Central as many of my plugins are older v9 plugins, even though they show up in Waves Central. So it would seem central only install v10 versions natively. The offline installer is a separate download only available from the Waves website.

I then used this file from with waves central and everything works now as expected in Cubase Pro 9.5.