WAVES V9 licensing problem

I recently updated to V9 and there seems to be an almost random problem with Cubase recognizing the licenses. What happens more oftern than not is I’ll load up a project and I’ll get a message that says that the plugins don’t have a license, and to "Please check that you have a valid license, then click “Rescan Licenses”.

My Waves License center shows all of my plugins as being acivated, and I’ve even moved the licenses off my HD to a USB Drive to see if that helps. In 80% of the cases, it doesn’t reccognize the licenses. I’ll reboot, and once in awhile, the licenses seem to “stick”, I’ll load up another project and the problem comes back.

I’ve reinstalled V9 and that doesn’t help.

Any sage advice anyone can offer!?


At the risk of sounding too obvious, have you contacted Waves support?

Cubase doesn’t “recognize licenses”. It recognizes VST plug-ins. If the plug-in doesn’t recognize that it’s licensed, then there’s a problem.

I’m not saying it can’t possibly be a Cubase issue, but I’d start with Waves, and if they tell you it’s a Cubase problem, I would push back and ask them politely how the hell that could possibly be the case, then throw in things like “didn’t you test this?”

All politely of course.

I run the V9 and I had some storage problems but now everything seems good (on USB!!), and I have not seen anything like what you describe here. License issue? Hm, that’s odd. Not seen that here. I wonder how long ago you purchased your waves? There’s always that 1 year thing with them on any updates. Which seems odd because you are able to run things sort of.

You are going to have to talk to Waves I’m afraid, that’s what I had to do. and it’s your best move. It’ll be slow going but they are nice.

Oh, one other thing? Open your Waves License Center and check there first to see your plugins, close it, and then open your Cubase. My opinion is that if you can see your licenses in the WLC, Cubase will start up and load your plugs, and that will be the end of it until you shut down Cubase. Once Cubase loads your plugins, it’s done I think. I can’t imagine what program is asking you to rescan your licenses unless there is a problem with the plugins directly. Then maybe the plugin tells Cubase there’s a problem and Cubase has to turn the plugin off - and then send you the notice.

OK, wait a minute? Your sig says you are running Cubase 32 bit? Why don’t you upgrade to 64 bit Cubase? The V9 is for 64 bit plugins, right? Maybe theres a 32 bit 64 bit thing goin on. :confused:

I would think it would install both 64 and 32 bit plugs. Every other plug-in that has gone 64 bit does.

Thanks for your input everyone. WAVES has confirmed that this is a known issue and claims its a memory problem. Apparently, you have a higher chance of this happening the more plugins you load. And since im in the mastering stages, I have a lot of instances of plugins (I suppose I could freeze most of them, now that I think of it) so my work around for the time being is to reinstall V8 for most of my plugins, and V9 for NLS (since that`s not available in V8).

Hopefully they`ll get it fixed soon.

Thx again!


I am having the same issue. My only work around is to save and save often. I hope they fix it soon, It’s beginning to be a pain in the but!


Just a bump… 9.r2 didn’t seem to help (me anyway).

I have been battling with the same problem here for a few months as well. Very very frustrating. I am awaiting a response from Waves. :imp:

I’m still having these problems. It appears absolutely random whether the Waves plugins recognise that they are licensed. Sometimes they open and sometimes they don’t. Sometimes the first one opens and then no more. Sometimes none at all. Sometimes I’ll get 2 or 3 and then no more,

I am running Cubase 6.5 32bit in Windows 7 64.

I notice that all these posts date back to 2012 - but I’ve still got the problem. Does anyone know what I can do?

I would appreciate any advice


Fantastic. 2015 and still the same problem. FTS.

Cubase 8.0.30 seems to have fixed this

So it seems that when I upgraded a piece of hardware on my computer (USB adapter) my Windows ID was changed. Therefore all the Waves plugins I had were now activated to my previous Windows ID and now not showing up in my DAW. FIX: Open Waves Central - click the Licenses tab - click the Disconnected Devices tab - there you will see all your licenses - select and move to My License Cloud - click My License Cloud and select and Activate to your computer - click the Connected Devices tab and you’ll see them in there now *Note that Waves allows you to move your licenses only once per year