weird auxiliary note in trill - solved

when i input a trill in a C-major score the default is to place a sharp above the trill (why?). i know how to change that but when i do, Dorico adds a strange parenthetical auxiliary note. how do i remove that?
Screen Shot 2019-01-07 at 7.59.45 AM.png
solution: in the ‘setting panel’ select as shown:
Screen Shot 2019-01-07 at 7.59.45 AM.png
unclear why the attachements aren’t showing up correctly. i will post the solution shot in a reply post at the end.

Properties panel. Loads of options there. I’d explain more fully but I previously wrote a whole article on it here: http://www.rpmseattle.com/of_note/create-½-whole-tone-flat-natural-sharp-trill-lines-in-dorico/

Is that a B? If it’s a diatonic trill, it shouldn’t display an accidental above.

How did you input the trill?

If the score is in atonal key rather than in C-Major, the default trill interval is always a major 2nd. That would explain the sharp above the trill.

pianoleo - thanks! i know how to accomplish what you’ve illustrated in your link. you misunderstand… i don’t want the auxiliary note at all. is there a solution for that?

dankreider - i selected the note i wanted to have the trill attached to and invoked the trill from the right-hand panel. the trill is input with a defaulted sharp accidental and the trill line. going to the properties panel, it’s easy to remove both the trill line and the sharp but when the sharp is removed the auxiliary note shows up. i want the auxiliary note gone but there doesn’t seem to be a clear way to do that.

András - thanks! i bet that’s it! i forget about the ‘atonal’ nature of non-specified key signature… i always assume ‘C’… but specifying the key signature as ‘C’ doesn’t remove the strange auxiliary note.

this is what i’m aiming for (from a Mozart string quartet score):
Screen Shot 2019-01-07 at 8.20.51 AM.png

Something’s off on your end, I think. I don’t get that result. When I input a trill in atonal, I get the accidental András describes. But when I hide it, I don’t get the aux note you’re describing.

Shouldn’t matter, but faster to use Shift-O and type “tr.”
atonal trill.png

the dialog:

i don’t see the option to ‘hide’ the accidental at all.

You said “you know how to change that” but I think you really mean “I used to know how to change that, before Dorico had a full implementation of trills”.

The old “interval” was just the number of semitones in the trill, so I’m guessing you set it to 1.

Now, it is the interval between the two notes, so it should be 2 for a second, and the new field to the right of the number lets you specify a major or minor second, etc.

So “1” now means “trill with a unison interval” and the only way Dorico can notate that in the score is with an auxiliary note. It only uses accidentals appended to the trill sign for intervals of a second. Trills can now be at any interval, including below the main note!

If you have now input a C major key signature, just delete the trill and recreate it, and you will get what you want - and it will play back correctly as well.

tbabcock, I’m guessing you haven’t upgraded to 2.2. That update brought many improvements to trills, as Rob says. You might be running 2.1 or earlier, just a guess.

The forum insists on autocorrecting your name to “rock.” So random… perhaps it thinks I’m being vulgar?? :laughing:

But if the interval is not set to 2, the “show/hide accidental” control hides/shows an accidental on the auxiliary note that you don’t want anyway, not an accidental next to the “tr.”

If you haven’t entered a key signature, this should give you what you want:

Dan, the OP must currently be on Dorico 2.2 or their screenshots would show slightly different formatting to the properties panel.

Tbabcock, I suspect you haven’t scrolled right sufficiently in the properties panel - there are more options than you think:

Yep, I suspect if I type TbabCROCK it’ll be fine :wink: