Weird behavior for "Enter Project Cursor Position"

Since ages I’m using the NUM [.] as key command for entering a bar position to jump to. This works also fine in CubasePro 10, but not when I use the key editor. I use the key editor as separate window, since I prefer to have this as a big window, not in the lower section (no need for me to see the project window when I’m editing Midi).
If I now enter a new position with NUM [.], a little time display shows up showing the bar I enter and the time (see below). In Cubase 9.5 I was just able to hit [SPACE] to start the playback, but this doesn’t work in CubasePro 10. I need to first hit [ESC] to get this little window to disappear, then I can start the playback. Another way to get the playback to work is to re-enter the exact same bar position, then this little bar/time display disappears. Obviously highly annoying and another step I haven’t had to do since I can remember.

I cannot find anything in the preferences nor key commands that would influence this. Seems to be related to the fact that there is no time display to the toolbar of the key editor (which I don’t need - I keep the window just big enough so I see the transport bar at the bottom). It works as expected in the project window. I would call this a bug, but I’m not sure if this is by design in Cubase Pro 10, which I would vote against if Steinberg could change this back.

Anyone else?
Screen Shot 2019-01-03 at 5.29.02 PM.png


This is an known issue of Cubase 10.

in Cubase 9.5 you wrote the new position and hit Enter. The Cursor Position pop-up disappeared. In Cubase 10 the Cursor Position pop-up stays visible after hitting Enter. So you have to close it manually (Esc) first.

It’s already reported to Steinberg.

Thank you Martin. Appreciate the insight, and good to know.