Weird mixer bug - adding or changing instruments resets all sends

I’ve been composing a lot lately with a combination playback template, involving NotePerformer as well as several custom VSTs for specialized sounds not covered by NP.

Some such special VSTs are rather dry out of the box, so I’ve been adding a reverb aux track and sending my tracks to it.

However I noticed that if I decide to add or change an instrument at any point, it will completely reset all the sends entirely (turning them off and also turning everything down to -∞):

Screenshot 2024-03-16 at 10.33.02 PM

Even weirder than this, at other times where I haven’t added any instruments, everything is sounding fine but I noticed a behavior where I will look at the mixer and all the sends are showing they are turned off and at -∞, yet I can hear reverb on those channels, and see my reverb aux is getting signal!

Another bug, I’ve also seen some non-NotePerformer channels which are definitely passing audio not showing anything on the meters at all, and even though I can hear them passing audio, if I solo such a track, it goes entirely silent.

Lastly, by way of feature request, I think it would be ideal to be able to double click any number field in the mixer and manually enter a number (sends, pan, volume, etc.). This way I can make certain levels consistent and also makes it easier to match previous settings precisely if I can type it in (just like in a DAW).

I’m running Dorico 5.1.21.2098 on a Mac M1 with Ventura 13.6.1. Let me know if any diagnostics would be helpful here. Thank you!

It sounds to me like the issue you describe with the Sends section in the Mixer might be a display problem rather than that the send is disabled altogether, if you are hearing signal go through your reverb channel.

When you say you are adding an instrument, are you talking about adding instruments to the project in Setup mode, or adding VST instruments to the rack in Play mode?

You can edit numeric parameters in the Mixer via Alt+click (as of Dorico 5.1.20), but you can’t use double-click.

With regards to this bug, I have two displays, and I have tried the mixer on both screens, yet it happens on both.

This bug (which is different from the other mentioned) is where I definitely do not hear any reverb – this invariably happens after adding a player+instrument from the setup mode specifically. No issues when adding new VSTs.

Noted, I wasn’t aware of this update. Thank you!

Hi,
After writing various projects within the past month, I can confirm this behavior happens consistently on any new project– specifically whenever adding any new instruments, all sends turn themselves off and down, and all panning resets to center. So I believe this to be a bug.

One thing I can say is that my workflow typically involves a hybrid with NotePerformer + VSTs for instruments which are not available in NotePerformer, so I’m not sure if it’s the combination of NP with various VSTs which might be creating this mixer funkiness, and if that might be more of a Wallander issue or not.

Would it be helpful for me to provide a project file or diagnostic report? Let me know, thank you!

I’m unable to reproduce this, so it would be helpful to have a step-by-step recipe for how to reproduce it. Are you able to reproduce it with one of the factory playback templates? Do you have an appropriate space template set up that is being applied?

Hi Daniel,
I finally had a moment to start with a fresh project and walk through step-by-step on how to reproduce this error.

After running some various tests, I can confirm that it does not happen with any of the native Dorico/Halion playback templates. The issue seems to occur when NotePerformer is selected as the playback template, but I go to add additional separate VSTs.

This is how I’ve been able to produce the issue from scratch:

  1. Starting with a new project and single instrument, with NotePerformer as a playback template, I create a new FX send, inserting Steinberg Reverence.

  2. I create a new player/instrument, ideally for one which perhaps NotePerformer doesn’t have or doesn’t cover all that well. In my case I’ve been writing a lot for saxes lately, which I have better libraries but their issue is they are too dry… Anyway if you go load a separate instance of Kontakt and just select anything that should do, but in my example I selected a tenor sax.

  3. Enable and turn up the reverb send in the mixer for this new instrument to confirm that works (I just went full blast so it’s obvious when it disappears).

  4. Finally, go to the setup menu to add a new player/instrument. Anything will do, I selected a clarinet.

  5. Obviously NotePerformer handles the new clarinet automatically, but if you play back, whatever you have written for the Kontakt instance (tenor sax in my example) should now sound completely dry. Viewing the mixer will confirm the send is now turned down and disabled.

I’m attaching the project I built here. The current Kontakt instrument should load with the send at full blast; if you go to add any new instrument, this issue will re-occur.

However if you are still unable to produce this issue on your end let me know, perhaps it is something wrong with my machine or installation or NotePerformer.

Thank you!

Dorico Sends Reset Test Project.dorico (948.1 KB)