Weird repeating engraving issue

I have fixed this in engrave mode at least 6 times now but it keeps reverting to this. It is initially from an xml transfer of a Sibelius file but I have added a large number of flows since then and I am not wild about recopying into a new Dorico file. Any idea why this keeps happening? It is extremely tedious to fix this every time I go to print the score.

Could you attach the .dorico file here, or a cut-down version of it that still exhibits the problem? Hard to diagnose from a screenshot if there are hidden things causing this.

First thing: get rid of ALL manual adjustments that you’ve made in Engrave mode. Then see whether the problem persists. Then try to fix it with Layout Options changes.Then, and only then, make small manual adjustments.

Ben’s suggestion of resetting staff spacing overrides is a good one to try - but if this is dynamic, i.e. the gaps between staves increases when you perform an edit, try saving, closing and reopening the project. It’s something that can occur, but iirc has been elusive for the team to track down.

If the second possibility is the case, do share the project (ideally with the “Silence” playback template applied, to reduce its file size) and some information about what steps you take that produces the problem.

1 Like

All for the entire project or just that specific flow? This is a 30 minute ballet so that would be a lot of removing.

Here it is. The issue always take place on page 4 (Part I: Opening)

Strangers Project.dorico (995.6 KB)

First thing I did was remove the manual staff adjustments on that page.
The real problem is that you’ve stacked Instrument changes, Text (“Play”) and Playing Techniques all at the same position.

Moving the text objects in Engrave mode doesn’t change how other objects respond to their default positions.

So, for the Text objects, first thing is to select them in Engrave mode and click OFF “Avoid Collisions” in the Properties panel. THEN position them. You’ll need to reset the changes to the other items.

Reducing the distance from the staff for all Instrument Changes also helps to bring things down a bit. Not sure why that “Ob.” is so high, though.

Anyway, once you’ve sorted out these issues, mostly at a global level or in Options: then you can make a few choice manual adjustments. I’ve made one adjustment to the top staff line.

Strangers Project.dorico (994.9 KB)


Thanks, I think I have sorted this out with the suggestions you made. I appreciate it.