Weird stutter issue --> [UR44/Yamaha P125] [Yamaha Steinberg USB Driver]

Hi everyone,

After doing a TON of searching and testing with no actual success, i’ve figured out that this is a good place to ask.

So… I have a UR44 for a couple of years now, it is working flawlessly (atleast for my basic uses for it).
A few weeks ago i’ve upgraded my basic Yamaha PSR Keyboard to a P-125 digital piano (also by Yamaha).
The PSR keyboard i’ve used as MIDI input for piano VST’s, it worked with the “Yamaha USB-MIDI” driver and everything worked fine.
The P-125 has it’s {aux in} integrated for playback-through-device by the USB connection, it shares the same “Yamaha Steinberg USB” driver with the UR44.

The problem is that, either sending playback audio through the P125 or using the P125 as input/playback device, Unfortunately ,each gives an unbearable stuttering audio stream (piano or playback accordingly).

I’ve tried :
->Resetting the P125 to factory defaults
->Tried to stress the USB transmission – tried a few voices - strings seemed to lag the most, held 2 sustained chords (can’t remember the setup,
whether the P125 was in/out) for a few seconds which led to a system freeze followed by the worst Bsod+crash+CMOS error and bios auto/restore
Those few horrifying minutes, waiting for the system to get back up… i was sure that the problem was a faulty USB port/controller on the P125, maybe shorting or voltage spiking, and i’m about to find out that my MB is toasted… :open_mouth: well, luckily no damage was done, everything worked as it was before - maybe the CMOS error happens on some rare buffer issues… can only guess…

Before concluding that the P125 was to blame, i went on and tested on my laptop - which is a new but really low-end 11.6" lenovo. Installed the driver, connected the P125 —> worked fine, both as output and input.

**i should mention that my PC is a bit old but highly capable, power settings on high performance, 12Gb RAM, CPU and chipset both run cool, system and chaches on samsung SSD.

There are hundreds of online posts and articles about USB audio buffer underruns/overflows issues, also alot of talking about timestamp problems with this specific driver.
Based on given suggestions i’ve also :
*Disabled network adaptors.
*Disabled USB ports (except for mouse/KB/P125)
*Updated USB port drivers, graphic card’s driver and BIOS firmware.
*Tested on minimal boot (no AV/firewall/office/tuneup/etc…)
*Uninstalled Intel RST
**Tested with LatencyMON and DPC checker - Sadly ( :wink: ) both gave excellent reaults…

All with no avail. (and twice barely dodged a system format)

Using the ctrl+shift+A in the driver’s control panel, tried almost every combination - noticed changes but no fix.

Just before giving up completely - tried launching Cubase, empty project->audio track->P125 as in and out—>windows sound options->P125 as playback device.
Enabled listen on the audio track and launched chrome/youtube/random music - my mind has blown, it worked perfect !

So it’s a little comfort, but not a complete solution because that way, whenever i wish to play, i’m tied to launch Cubase and go through those small but annoying configs ----- instead of just powering up and playing, as i do with the UR44…

Help would be much appreciated :slight_smile: