Well recorded piano sound


I would like to record the sound directly from the digital piano to an audio track. I need to get the best from the piano in stereo mode. I bought a high-end HW, Piano Roland FP-90. Its sound is amazing. Using headphones the sound is like in a dream. I am planning to record several instruments, so I’ve bought Steinberg UR-RT4 and two TRS professional Roland cables well shielded 5m in length. The piano is connected from both line-out outputs to two MIC/LINE inputs. Despite the investment being high, the piano sounds very poor through the Steinberg sound card. The quality sounds like from the several times cheaper piano. I played with the volume on the piano, and on the line inputs volume knobs, but I am very sad about the sound quality. When I plug the headphones directly into the piano, the sound is brilliant. When I plug the headphones into the sound card, I want to vomit. I am not sure whether I set something wrong, or waste a time investigating the problem in the case of faulty devices. Do you have an idea what could cause the issue?

Does it sound bad only while monitoring through the interface? How does it sound when you listen back to the recording? Does it sound ok then?

By default all channels in DspMix are panned center. So you are effectively listening to your piano in mono while using direct monitoring. But this should be easy to check and also to fix if this is really the issue. Just pan the two channels hard left and right.

WoW. Yeah, You found it! Thank you. Now the sound is almost the same. I am just wondering, why the signal is so silent. When plugging the cables to channels 1-2 or 3-4, it is briliant. When plugging the cables to 5-6, the signal is silent. Unfortunately there aren’t knobs for channel 5 and 6, and virtually in DSPMix they are on MAX. Is that because of differce resistace for a difference purpose? I have to turn the volume up to MAX in piano to get a sutisfied volume from headphone monitoring. But I am worry about sending the max signal to the device. I don’t want to burn it out. It doesn’t have any indicator of peak for the mentioned channels.

Kind Regards

When you use inputs 1 - 4 you are adding gain to the signal. The peak indicators are there to help you with setting up gain.

Inputs 5 and 6 are line inputs with no gain controls. You can switch the input sensitivity in dspmix settings. Try -10dBV. It should be louder than +4dBu. It will only be as loud as the signal coming from your piano (or whatever you connect). You can always turn up the headphones volume if you think it’s too quiet.

When I connect my Yamaha keyboard to inputs 5 and 6 I have the volume all the way up on the piano and I still have some headroom. While you don’t have peak indicators you should still be able to see the signal on the meters in dspmix.