Went from 4GB to 20 GB of RAM, no change in CPU meter?

Hi, all, first post on here.
I am running the latest update of Cubase 7 on a mid 2011 iMac with OSX 10.9. I have a 2.7GHz Intel core i5 system.
Originally at 4 GB of RAM I could run an instance of Superior drummer plus 5 more audio tracks with plugins at about 70% CPU. I just upped the RAM to 20GB, but the CPU consumption is still the same.
I was expecting the meter to go down quite a bit and it has not changed. Am I missing something?
The RAM is installed correctly. I don’t know if there are any additional steps I need to take after installing it.
I left the original 4 GB of RAM installed and added 2, 8GB cards in the other slots. Any help would be greatly appreciated.

Thanks in advance.

just a guess, but could it have anything to do with only 4gb ram being utilised because of 32 bit limitation, like windows sort of thing?

edit: just re-read post and realised that its cpu meter your talking about… i guess it may be expected that increasing ram could take some of the load off the cpu, or perhaps not though?

Well the extra ram will certainly take a load of disk streaming, paging etc, especially when using the likes of Kontakt, Play, Halion/HS and the new GA SE so overall performance should be far better. Have you gone into the setups of all your sampler/romp lets etc and optimised the engines in them?

You’ll notice the benefits as the projects get larger :slight_smile:

Why?

I do not know how or whether this translates to Macs, but on Windows, increasing RAM only improves performance if you were previously thrashing virtual memory on the hard disk due to being out of physical RAM. All other things being equal, if you had enough RAM at 4GB to load the project without abusing virtual memory, you wouldn’t see any performance benefit when loading the same project after adding more similarly-rated RAM.

‘UltimateOutsider’ is correct, more RAM does not equal more processing power, but does equal more memory space.
That means you can run more instances of memory hungry VSTis such as, say, Kontakt, Omnisphere or Superior Drummer.

Mauri.

In simplest of terms, your CPU will NOT change by adding RAM. To change CPU meter, you change the CPU…heh.

RAM allows your VST to load more samples.

  1. Plug ins at 70% usage sounds like the i5 isn’t getting it done, unless you don’t plan on using more plug ins I would look at the i7 chip, and since you now have more ram you could then load up more plug ins as others have mentioned.

are you classing the Asio meter in Cubase as the cpu meter ?

Thank you all for the replies.
I have yet to look at the actual VST meter to see if it has changed, which it probably has. I figured since the CPU meter increases and decreases as you add or remove plugins, that some additional RAM would help ease things a bit. Evidently I was wrong.
Even so, I’m surprised that with a 2.7GHz quad core i5, that I do not have enough power to run a medium sized project with my mastering chain engaged and Superior drummer running.
S2.0 is my only virtual instrument so far, with an instance of slate VCC on every track. If I engage my mastering chain, which is just the FG-gray compressor and Ozone 5, the computer gets overloaded. I’m talking about maybe 12 tracks for superior drummer, plus 4 guitar tracks and 1 bass track. The reason for wanting to run S2.0 rather than bouncing the files down, is to keep from continuously re-importing wav files if I feel like changing a snare or kick in a mix.
Does anyone else think the system just isn’t cut out for what I’m trying to do?

Thank you all again.

Not sure the inherent differences between Pro and iMac, but my old 2008 has 8GB and can get fairly further than yours.
I’m a bit surprised that you’re getting stuck at 17 channels even with console, etc.

I can use NLS up to 20 channels, about 6 VST, and have room left for 3-4 hungry plug-ins, the left I leave to my UAD.

That said, with things like 8X oversampling, or maybe non VST///, or maybe VST///, but perhaps at some point in a tune, 3 hungry plug-ins are working at the same time. I do try and delegate so that I’m using one big plugin per moment, and not chains of stuff running at once. I try to get things to ‘take turns’. Don’t know if any of that helps, I know it doesn’t resolve the frustration of still expecting to work freely (on an expensive Mac).

I would still look into it further, continue to ask the experts. I believe you should be able to get a little more. Oh check your buffers, depending on the circumstance(ime), it may work better lower (512, maybe lower at times) or higher (up to 1024). Consoles on every channel ime, I like to lower it. Otherwise I WILL get dropouts.

FGX is one of the biggest CPU hogs going…save it for mastering.

You haven’t mentioned (or I missed if you did) anything about interface or what buffers you are running at. Maybe you just need to increase your buffers?

Hey there,
I’m not using FG-X, but Ozone 5 rather. Not sure how they compare in terms of consumption. I prefer having the mastering chain engaged fromt he start and toggle it on and off, but it’s not as big a deal if I can’t run with it. My interface is my axe fx. I’ll have to check my buffers and get back to you, as I don’t know them off the top of my head and I never really set them. They just are what they are and I have unnoticeable latency while tracking. Re-amping does lag a little bit and requires manual placing. I am sampling at 48k, which is what the axe fx samples at.

I do not currently have any external drives. I hear of people using as many as 3. One for the O.S., one for the VST sound libraries, and one to record into. Does splitting things up this way optimize the CPU load?

Sorry for all the noob questions. I’ve been recording myself inefficiently for years and working on some project for a local church has me committed to improving my system and overall experience :slight_smile:

Thanks again.

The meter in Cubase is an ASIO meter, not CPU.

^^ Yes, ETB, I realized this after reading a ton of threads. I apologize for my lack of understanding.
I appreciate everyone who is chiming in and trying to help out.

I am currently recording in 24 bit, sampling at 48k, and my buffer size is 256. I hope you can see the screenshot I have attached and maybe reveal something else I’m not seeing. I’m not improving performance by shutting down my wifi. All energy saving options are also disabled. Is there anything you’d change?

Thanks again.
Screen Shot 2013-12-10 at 7.52.49 PM.jpg

I don’t know if this applies to macs, but have you tried disabling ‘Asio Guard’? It makes a big difference in my Windows 7 x64 setup.

Mauri.

I looked at your screenshot and the first thing I noticed was "131 processes running"! :open_mouth:

You really need to go through these and turn off anything that isn’t necessary.

Sure, I’ll research and see what processes I can safely close out, but are they having an effect on the ASIO meter despite having 0 load on the CPU?
If all else fails, would a Solid State Drive improve the situation?

Solid State Drives will enable your applications (including the operating system) start up quicker but will not really add any processing power. It might be my imagination but I feel they do make the system ‘slicker’.
SSDs wuld also help if disk speed is an issue when running lots of tracks or/and samples.

I’m using 4 SSDs (no internal disks) and am very happy with that setup. All in all, I think SSDs are great.

BTW, my non internet Cubase/OS has 28 processes running when idling.

Good luck,

Mauri.

I’m don’t think they have any effect on the ASIO meter, but eliminating a lot of those processes will free up CPU (all those processes are running in the background).

Check out Black Viper’s website for information on what can safely be turned off …

http://www.blackviper.com/.

Bluzkat, thank you for the link, I’ll check it out tonight.

The CPU, if you saw my screenshot, is under 6% when the VST’s are around 50%. When I engage the mastering chain and the ASIO meter maxes out and completely ruins playback, the CPU is still at less than 10%.

So far, from all the threads and articles I have read, the only offered solutions have been to freeze tracks (which doesn’t really work when mixing and constantly going in and changing vst settings), increasing the buffer size (I am currently at 256 and don’t use input monitoring when tracking, so I need to experiment with this during mixing), or getting rid of Cubase altogether and switching to some other DAW), or bouncing my superior 2.0 MIDI into audio tracks and re-importing them as .wav files prior to mixing (annoying to have to do this every time I decide to change a snare drum or cymbal, but I’ve been doing it for a while).

No thread I have read has ended with someone saying “fixed! here’s what I did,” which is very disheartening. I wish I could compare Cubase 7 on a PC to see if the ASIO meter maxes out as quickly as the MAC due to the Core Audio bottleneck I keep reading about. As far as I know, my machine is up to date with OSX Mavericks.

I guess I feel let down by the expectations and the reality. I’ve also contacted support directly to see if they can help me better set up the computer or the DAW itself. I’m using stock, Stillwell, Waves, and Slate plugins. Does anyone know of issues with those?

Thank you all again.