What am I doing wrong?

Hi, just getting started with Wavelab after switching over from Bias Peak and have hit a snag, it’s probably something very basic that I’m doing wrong but so far can’t solve it, have searched forum and help file.

Here’s problem, I open a song mix file to master, open some plug-ins in master section (in this case bx dynEQ V2, Dynamic Spectrum Mapper V2 and bx XL V2), adjust to taste, check meters in master section (no red showing), then render file.

It goes through the rendering process and rendered file shows up in new tab but resultant file is distorted and over compressed, it sounds as if it is running back through the master section thereby applying plugins twice but is not. Ive tried reducing levels but I get same distortion and too much compression at a lower level. I go back to un-rendered version and monitor through master section and it sounds fine. Have not tried other plugins yet, could there be an issue with these?

Hence my question, what am I doing wrong?

edit: tried different plugin set and did not experience the same problem with these plugs - bx dynEQ V2, Dynamic Spectrum Mapper V2 and bx XL V2?

Once applied, if your plugins are still in the Master Section, you play through the plugins again. there are several ways to avoid this, eg. click on that button:
This could be toggled automatically after rendering, if you want (Render dialog option).

Thanks for the reply, but the problem persists. This is a bit hard to explain so please bear with me.

I can turn off " monitoring through master section" which does make an audible difference (as it truly is being run through the plugs twice) but the rendered file itself is still not right when monitoring with no plugs. This only happens when I use it with the plugins I mentioned (btw, all from Plugin Alliance). These happened to be the plugins I chose the very first time I open Wavelab to master a song so I thought I was doing something wrong and spent a while trying to figure it out. When I finally dumped those plugs and tried some others (Steinberg Multiband), the program behaved as it should and the rendered file sounded exactly like the unrendered version does as played thorough the master section with plugins added. With the other set of plugins,the rendered file does not. It is over compressed and distorted and sounds ‘as if’ it were ran through the plugs twice when monitored clean and gets even more so when monitored through master section.

Since it seems to work ok at least on the few other plugins I’ve tried, I an now wondering if is an issue with one of (or all) of the three I first tried which are bx dynEQ V2, Dynamic Spectrum Mapper V2 and bx XL V2.

I have not tried testing them all separately as I only had so much time to mess with the program and needed to get some work done. Are there known issues with any of these plugs or a list of non working plugs somewhere so that I know what to stay away from?

Thanks, Stephen

Again following up on my own post just to update for anyone who may experience a similar problem.

I got time to experiment with wavelab and plugs and found that my problem was caused by the VST3 version of Dynamic Spectrum Mapper V2, btw, a great plugin. The VST2 version seems to work fine. When rendering a file with the VST3 version it seems to somehow over-apply the effect of the plugin (as if it were running it through twice) and also disables the function of the monitor through master section switch on the resulting rendered file. I’m not sure what causes this, wavelab or DSM v2 VST3, but as long as the VST2 version works, I can get my work done.

It’s unfortunate that I encountered this problem the very first time I used wavelab as it led to a lot of confusion when it wasn’t working properly. Now that I’ve had a chance to get around in the program when it’s functioning properly, I can tell I will enjoy using it as long as I don’t run into too many situations as the one I did at first.

Anyway, this should be added to a bug list.

Thanks, Stephen

I got the DSM at PA’s “Fire Sale” some weeks ago, but haven’t actually tested it in WL yet. I will take a look and see if it’s the same in my system.


Hi smartinuf …

I have had the DSM from when the first version became available as I am a big Paul Frindle fan.

Like you I am finding issues with the ‘new’ V2 version. On my system (latest version of WL7 and XP Pro SP3) the plugin does not appear to actually ‘limit’ the output even when the limiter is engaged. You can see the signal on the plugin’s out meter confirming this. You can lower the input signal to address this but it kind of defeats the purpose of the exercise does it not?

It’s quite unusual behaviour.

I haven’t had the chance to explore this or report it yet to the developer and to be honest I don’t really use it that often.

I still have the V1 iLok secured plug installed. That continues to work fine.

FWIW, I have had ‘trouble’ generally with Plugin Alliance installs that were not previously an issue with the older iLok versions. This may well be a consequence of not getting around to installing Windows 7, I don’t know.

Bottom line? I do not believe it’s not a WL issue.

Hope this reassures.

Thanks for the replies, it could very well be a problem with the V2 VST3 version of the plug or Plugin Alliance copy protection scheme, I don’t know and not explored the issue from that side, but will when I get time. Right now I’m happy that it’s working with VST2 is working so I can get stuff done. Didn’t buy the plug until after the PA switchover so have no experience with V1. I’ll also check the limiter as I remember a bit of funny business with it as well.

Thanks, Stephen

I haven’t had time to test the DSM in WL yet, but beware that there is a new version out (2.0.3), which perhaps fixes the problem?


Thanks, I’ll try it and report back


And I guess for the record I should make it clear that there is absolutely nothing in my previous post that is meant to imply that there is anything ‘wrong’ with the quality of the processing and sound of the DSM generally. I have used it personally as a final limiter on releases which have literally gone to the top of the national charts and have won national awards. So, there’s nothing wrong with ‘the way it sounds’.

The DSM has had issues rendering. I’ve talked with Plugin Alliance about this just after their last (2.0.2) update. They are aware of it but haven’t been able to find the problem. However I wasn’t aware of the 2.0.3 update - I’ll also need to check it out.

In the meantime, the solution I use is: to record the file ‘live’, setting the WL record interface to ‘record what is played back’. Takes longer but it works.

Due to an extremely busy travelling schedule I still haven’t had time to test the DSM in the studio, therefore, question: are the problems only on MacOS or under Windows as well? 32 and/or 64-bit?


I’m on Windows 7 Pro 64 bit. Although I’m still currently using WaveLab 7.21 32 bit version.

2.04 is out. Will install that one before checking.

Edit: Did the test: WL7/64 + DSM 2.04 VST3/64 rendered just fine, no “double rendering”. Disclaimer: I did not check the 32-bit and VST2.4 versions.