What can you do about clipping when setting levels?

So I’ve noticed that Cubase (unlike many other DAWs), does not alert you to potential clipping when live monitoring an audio input.

Despite being very careful and recording with very moderate levels, this has bit me in the ass a few times. A musician changes a pedal, sings much louder or something and then there ends up being some clipping in the track. In the DAW that I’m used to, I am alerted to this immediately by a clipping indicator on the track.

So is there some feature I’m missing in Cubase to show clipping on the audio input? Or an easy way to notice that this is happening?

Also, I prefer my metering post-panner, but with the compensated pan law, this means that inputs clip at ~3db. That’s very confusing. Once again, Another DAW™, switches metering position when record enabled so that is bypassed. Is there anything I can do in Cubase to deal with this?

Cubase does have clipping indicators on the input channels

Set the pan law to 0?
Apart from that, monitoring input levels post panner takes much more into account than just the pan law, so IMO not reeally useful anyway.

When you set up peak holds in the mixer (right click a channel as I recall, bottom somewhere), if there is a clip it shows read and stay there


Input and output channels show clipping.

I have set the color in the metering to RED when it hits -3dB, and removed the gradient color fading.

If you have “Map Input Bus Metering to Audio Track” set to ON, you would have the pre fader metering shown ?

I seem to be missing something. I am not getting any clipping indicators at all on input channels or the track that’s being recorded. (Meter position is set to “input” for these images)

I’ve checked this in 4 other DAWs and for the exact same routing and input, they properly show clipping.

No? I don’t get that behaviour at all. If I have post-panner metering on, it always shows post-panner metering. Maybe I’m misunderstanding something.

The 2nd pic is showing clipping on input 2.

The red at the bottom is the clipping indicator?!

What a very strange place for it when every other meter out there puts clipping indicators at the top of the meter, right where Cubase has an empty spot (on the input meters).

Is the only place you can see input clipping on the input channel at the bottom then?

Yes. That is where the clip is shown. I Know, strange place huh? …

I can get used to that, even though I’m obviously annoyed that it’s there to begin with.

The thing that really bothers me is needing to have the input channels up all the time (as I switch I/O frequently during sessions).

That’s a lot of screen real estate wasted.

IDK, it is nice to find a big red warning above a clipped track that may not have been seen in the current view. Then you know you screwed up somewhere.

I suppose I don’t exactly understand why you are any where near the clip level anyway. No reason to be anywhere near that point. Not in a digital recording situation.

There is really only one channel you really need to worry about, and that is the master out. Though you could have input clipping and those should be nowhere near 0dBFS.

I’m missing something. Where is the warning above a clipped track?

I set my levels very conservatively (~-20dbFS peak), however due to the nature of the recording I do there is a lot of instrument/mic/input switching. I don’t run in to clipping issues often, but there’s certainly times where it slips by when someone adjusts a pedal or smashes a mic with a stick before a take or decides to step in to the mic etc…

Usually in the DAW that I’m used to, I see the red clipping indicator out of the corner of my eye and I know something has gone awry. Then I know it’s time to go see what’s up.

I’ve been bit by this with Cubase a few times because I didn’t catch it. Rather annoying.

I’m not sure what you’re suggesting. If the input is clipping, then it’s clipped. The master channel is irrelevant really.

try this, R click on a channel, head for global meter settings. Tick hold peaks and hold forever. After this when a channel peaks the peak line will show red

Something that might help is that Cubase has 3 mixers that can be set up individually.
Use one of them to only show inputs, and assign a hot key to it. And what really helps is to reassign those colors on the meter, mine is in the green up til -12dB then goes to yellow and at -3dB it goes to red, with peak hold ON as suggested. That helps me keeping my levels down, well and a hardware limiter on the vocal channel :slight_smile:

clipping is also shown on the transport for the standard input bus.

As said “meter input”, and you can see it directly on the audio tracks.

Using another mixer is a great idea. Thank you. I’ll also mess with my meter colours a bit.

I double checked this, and the transport meter never clips for me based on input. I’ve even tried having 32 input channels clipping at the same. The only thing that shows clipping here is the input channel.

In the above images, I have “Map Input Bus Metering to Audio Track” and the meter is set to input. As you can see there’s no clipping shown, despite the input channel showing clipping.

I don’t think “Map Input Bus Metering to Audio Track” is useful to me at all since I’m not using Direct Monitoring (It’s not even an option if I wanted it, which I don’t). This isn’t an issue in any other DAW that I’ve tried (I’ve been sanity checking myself while writing these posts).

Gain staging from the get go… is my suggestion.

No need to get close to 0dBFS when tracking… Keep transient rich signal peaks (drums, perc, etc) at -6dBFS, and longer sustaining signal peaks (distorted guitars, keypads, etc.) at -12dBFS…

This is about the same as proper use of a VU-Meter calibrated to 0dBVU = +4dBu (1.23V) = -18dBFS… The easiest possible explaination I can come up with to keep you in the ballpark.

I already explained why this is not a complete solution. I generally record much more conservatively than what you’re suggesting. Thank you though.

Can we please just discuss the clipping indicators in Cubase?

The transport mirrors the output and it should definitely show clipping if the output is clipping. Of course if you’re running into a limiter on the stereo bus it won’t or if you have the master fader turned down it may not.

That’s correct, this only works if you have the option to enable direct monitoring … so is no use if your interface isn’t compatible.

Here is an image with global meter position set to “input”. Track 15 “Guitar” is clipping and a clipping indicator is showing on an input channel off to the left.

As you can see the Master and Aux are not only not clipping, but they are -3db due to the pan law. The primary track has no clipping indication. This is despite the meter position being set to input.

I’m feeding relatively a relatively high-voltage signal from a signal generator. I’ve checked and every other DAW I own shows this as clipping correctly. The focusrite and RME mixers also show it as clipping.

What am I missing here?

I don’t think you’re missing anything. This is just how it’s been designed.

The input channel correctly shows clipping, the recording channel never does but I suppose you could argue that channel isn’t actually the thing that is clipping.
But with meters set to input, I agree it would be good to see clipping of the input channels also on the record channels.

I had forgotten pan law will affect the stereo out so yes, unfortunately this will only indicate clip at +3db or more unless you use the 0db pan law.