What/Where is the Quit command & what's with the "menu bar" in Cubase 10.5 on Windows?

For years I was a MAC OSX guy and now I have got a second Windows 10 system and installed Cubase 10.5.
When we close the Cubase its not actually closing the program bar at the top still there. (Like mac osx)
In the past it was not like that in windows 7 as far as I remember. Is this because of Cubase 10.5 or windows 10 and more importantly can we disable this future ?

The top bar should definitely close (be gone) if Cubase is actually closed.

Did you just close a project and not Cubase?
Maybe a 3rd party VST is hanging and is preventing Cubase from actually closing.

Check the Windows task manager to see if it is actually closed.

Regards :sunglasses:

On Windows 10 you have to explicitly quit the application, as opposed to closing the editors and project windows.

When you want to quit, use File>Quit, which you can assign to a Keystroke in Key Commands.

FWIW…
I usually hit File>Close (Ctrl+w) to close the project. Wait a few seconds to make sure it has closed properly, then hit the close “X” in the upper right hand corner of the Cubase main taskbar. Never had an issue.

Regards :sunglasses:

Oh my god is this a windows 10 thing ?

No, if by that you mean, caused by Windows 10.

Yes I mean is thisa caused by windows 10

What is “caused”?
I dont see any issues here. If you have the project Window maximised you close the project, not cubase. This requires of course to click the close mark on the title bar or the corresponding key command.

This is not caused by Windows 10. It’s a UI design choice on the part of Steinberg. The OS evolved, and SB has to make a change.

Some people don’t like it, some do. Personally, I like it for the very reason you started this thread… Cubase can remain open when all other windows are closed. If I want to quit Cubase with a project open, I use the Quit command. The only change the user must make for this business is to change the command used to get the desired result. In your case, hit Quit.

Cubase has lots of quirks like this with window behaviour. The interface is, quite frankly, a mess. Any other application with just a single project/document open will exit the entire application when you hit the close button in the corner. Windows that you expect to stay on top disappear backwards if you so much as look at it funny - very frustrating.

I don’t mean to debate the merits, but I would point out that on Windows 10 whether an application exits or not when all windows have been closed is a choice made by the programmers of that program. There are many programs that continue to run after their windows are closed.

Cubase will indeed close when you hit the the close box in the upper right of the so-called menu bar- but that UI element is, programmatically speaking, actually a window. So when that is the only open window, it does indeed exit the program.

Using the command File>Quit closes the application without regard to windows being open.

Keyboard shortcuts is your friend.

CTRL + Q : Quit Cubase

CTRL + W : Close current project.

Just for info - I do CTRL + Q - but I still see Cubase is ‘open’ in taskmgr (w10) - I have to THEN right click on that to ‘end task’. Kind of a hassle and when I forget to do it in a day’s work - I could have 4-5 of those lines ‘left open’ in the task mgr. Has never caused a problem - just seems like unnecessary step. :frowning:

It’s actually supposed to not work like that, and I have seen that kind of thing with Cubase and other programs over the years. iirc the last time I saw that it was solved by an un/re-install. I never did get to the bottom of what was going on though…

Several versions back I got in the habit of

  1. Closing the Project
  2. Waiting five seconds or so
  3. Exit Cubase

Which seemed to clear up having Cubase hang on exit. It was some time ago so I’m a bit (maybe a whole byte) hazy on the specifics. But if I recall correctly (huge IF) I thought that when the Project closed it took awhile to disengage from the UAD hardware/software and if that wasn’t finished then trying to close Cubase sometimes resulted in a hang. Again, I don’t recall at all what led me to think that was going on.

I wonder if a Macro could execute the sequence above, part of which would need to happen after the Project closed.

Yep for me a smaller template doesn’t seem to ‘not close completely’ - but for sure my 1000 midi track orchestral template 100% of the time never closes completely. I am looking at task mgr all day (w10). :frowning:

Thanks everybody one more and another question !

When we close the cubase project a menu bar is still there on the top. Its ok Im familiar with it from mac osx BUT when I click to something for example a folder on my desktop etc… the menu bar which showing Cubase menu turns into white and it seems REALLY UGLY…
Is there a way to disable this menubar ? In the past on Windows 7 or XP I dont remember this menubar thing am I right ?

A bunch of versions back, every Window (editors, settings, etc.) that you opened could only live within the confines of the Project/Background Window. So you couldn’t put an editor Window on a second monitor unless you stretched the background onto the monitor. When they changed it so that the various windows could float independently - that’s when this weird menu bar appeared. If you maximize this bar (not the Project window) it will show a black background that covers your desktop. If it is not maximized it doesn’t have the background and you can see your desktop below the bar.

In any case the bar itself never turns ugly white for me. Are you perhaps on a Mac (this is one of the reasons we encourage folks to put their DAW specs in their signatures :wink: )

If you think of the “Menu Bar” as a window itself, this will make a bit more sense maybe. You can examine it using the window spy that comes with Autohotkey.

On Mac, the menu bar is at the top, and the windows have always been separate, which is why no one on Mac brings this up. Also on Mac you don’t get menus inside the individual windows.

To be more clear Im posting a video
https://youtu.be/hwjsjdLQ80I