What would cause delayed onset of constant crackles?

I just got a new laptop and am getting constant crackles on a project that ran fine on my previous laptop. However, the crackles don’t start until several minutes after opening the project and they start off with one or two and slowly build until they’re pretty constant. The delay scales with buffer size - larger buffers result in longer delays until the crackles start but once they start they progress until they sound about the same. So buffer size determines when the crackles start but not the severity of the crackles.

Also, the crackles occur without any indication of audio dropouts on the Cubase ASIO meter. The meter never shows an overload.

Can anyone think of how I might fix this problem? Or what could be causing it?



Pc or Mac?
Version of os?
Audio interface?

Tried cubase 11 with same project by any chance?

It’s a pure guess, but it could be a misbehaving plugin. Try eliminating plugins step by step and see what happens.

Have you turned off all power saving settings?

What you are describing sound like you have some programs that run in the background and are doing a system check or virus scan periodically.
With higher buffer settings the audio engine is less susceptible to dropouts, so the crackles come later in as the CPU usage increases. You must find and disable these programs on startup.
As for the Performance Meter in Cubase, it is normal that it does not increase when this happens, because the CPU usage is from another program, and not from Cubase, the audio engine has then nothing to report since it is indeed not overloaded. It’s the other programs that steal the ressources.
And since it’s a laptop, you should try using the High Performance power plan.

Thanks for the replies - I think I’ve narrowed it down to a USB problem. The RME babyface that I’m using has a counter that shows USB transfer errors and it starts going up when I hear the crackles. That explains why I don’t see any indication of dropouts in Cubase - the audio is fine when Cubase sends it out. It gets corrupted during the USB transfer.

Also, the project runs fine using onboard audio, another indication that everything is fine in Cubase.

Still doesn’t fix the issue but at least I have a good idea where to start looking.


Sounds like you have some good clues already where to look.
I would check the following as a next step assuming you are on a Windows machine.

USB Hub power management in the Device Manager
Make sure this setting is off in all USB Hub entries.

USB Suspend setting
Make sure these are disabled.

Hi mlindeb - thanks for the info. I did make sure all USB power management features are disabled, so that’s not the issue but definitely a good place to look.

One interesting thing is that my system does not have “USB settings” in the power plan settings. But all other settings there are set for max performance.

Thanks again

Do a quick google search and you should find a number of methods to show those settings.
Have you been in contact with RME about this?

Yes - I have a support request in to RME and a thread on their forum.

Is there any value in setting the USB power setting in the power plan dialog if you set it in the device manager? Seems device manager would trump power plan settings.

I can’t get the USB settings to appear in the power plan options.


It seems logical that it would, but I don’t know for sure. Sorry.

I think most people are misunderstanding how USB Suspend really works. The purpose of USB Suspend is to disconnect (cut off the power) single USB ports from a hub without affecting other ports. This only works with select devices, and these devices need to send a specific message to tell Windows to shut them off. This has been designed for products like fingerprint readers, that aren’t needed anymore once the user has logged into the session.
The setting in the power plans Power Options acts as a global switch, and the one under the devices properties serves to allow it on these devices individually.

An audio interface is an active device that requires to be powered all the time, simply because the inputs and outputs are being actively in use by Windows, they must remain selectable at any time. For this reason such products don’t send the “turn me off” message, same as your mouse and keyboard. Imagine if you don’t touch them for a few minutes and when you come back they have turned off, you will no longer be able to control your computer… But again it doesn’t even work like that, this was just an example to give the idea.

Anyway, if for any reason USB Suspend was interfering, or taking effect, with an audio interface, it would not produce any crackling in the audio stream, the device would simply turn off completely…


Thanks - that makes a lot of sense and explains why I’ve never seen any difference when changing those settings.


Have you tried just using another USB port? Or swap the USB cable? (I couldn’t really explain how a cable could produce errors after some time of usage, but it’s an easy test to do).

Yes, I’ve tried all available USB ports and the behavior is the same.

One important discovery today: I do not have the problem when running on battery. The problem occurs only when plugged in.

I don’t think electrical noise would be an issue - everything is powered through the laptop (i.e. no potential for ground loops). I guess maybe there could be something about the charging circuit that is driving noise into the transfer but it seems it would be defective to the point of not charging if that were the case. But I’m not sure about that.

So there must be something about the high-power state that adversely affects the USB transfers. Odd, because it’s usually low-power states that cause issues.

Any ideas what that might be?


No immediate ideas, but to further isolate the problem, I would
A) go someplace else with the laptop (friend’s house, whatever) and repeat test
B) use another power adapter (if you can find another on that fits)

If both of those yield the same results, it is the laptop (maybe something heat-related?)

Have you checked the vendors site of the laptop to see if there are updated drivers or a new bios? If that doesn’t help it might be a faulty power adapter or in the worst case the voltage controler on the main board. Because it seems to run fine on battery power?

A little trick you can also try is.: Shut down the laptop an disconnect the power adapter. Now press and hold the powerbutton for more than 40 seconds. Let go and wait for 10 seconds before switching it on again.
Check if it operates oké now with the adapter.

I have the same exact problem.
Running on a ryzen 5 3600xt with nvidia graphics and RME babyface proFS.

It happens with cubase 10,11, 12
I start without problems and with a reasonably small buffer (128). As work is progressing and I go on with my project, crackles start to appear without apparent load on the meter.
These crackles will add up with time.
At that point if you go to cubase/studio/studio setup/reset ASIO everything comes to normal.
If this does not have any results the other probable solution is to change the buffer momentarily i.e. from 128 to 256 and back to 128 and everything is OK.
However if the crackles have added to greater extend even these measures don’t bring any results and you need to restart cubase. Sometimes even the browser will also crackle and/or speed or slowdown the playback of videos etc. That tells me it is a matter of clock or sample rate but all these are matched before starting to work on the project.

Interesting is that this can happen even if you open a project to work on, do nothing, leave it sitting there and return after half an hour to resume. It will be crackling like hell.

I have learnt to live with it.
I have asked and asked here and there and in RME forum and noone has come up with something.

It goes without saying that all these remedies proposed above in this thread have been meticulously applied again and again.