When changing tempo, nothing stays on the grid

Hey guys.

I’m working on a sample loop right now. When I change the tempo of the project in Cubase 9, the grid changes but my audio clips don’t stay on the grid. You can see what I mean in the two pictures I attached.
In Cubase 8.5 I can create a loop with audio clips and change the tempo and everything stays on the grid. How can I do that in Cubase 9?

I’m not talking about stretching the audio file. No musical mode.

Greetings


Click this button:
https://i.imgur.com/JDaRnR0.png

This is a different musical mode from the one in the info bar, which applies time stretching.

Thank you very much! It’s working now :smiley:

Just to clarify since this causes confusion for so many folks. This does not change change the Mode of the Track. Tracks don’t have Modes. This button changes the Timebase of the Track.

Musical Timebase means items on the Track are anchored to bars & beats.

Linear Timebase means items on the Track are anchored to hours, minutes & seconds.

Musical Mode is a setting that applies to Audio Files & can be set in the Pool. It enables audio to be stretched or shrunk when the Tempo changes. In order for this to occur the file has to be set to Musical Mode AND the Track needs to be set to Musical Timebase.

Nice for explaining, but the new guys will continue to make the same mistake till the cows come home. Amazingly bad choice of terms for those two functions in that respect.