When "Use System Time Stamp" doesn't help?

I tried using “System Time Stamp” for both “Windows MIDI” and “Direct Music” for normal and emulated ports trying to fix the problem of notes getting recorded too early (about 1/16 too early all the time). it doesn’t help, what can I try next?

I tried recording MIDI in FL-Studio to test if it’s my midi interface, the notes were placed exactly as played, not too early not too late. So it’s not a problem with midi interface

or there is just no solution for this? If I got midi getting recorded sloppily I just gotta keep on shifting the notes after each record take and than quantize?

What device are you experiencing problems with?

motif-es: contoller, Cubase: sequencer.


As far as I knew, the Motif (original) had problems with MIDI and timing but supposedly it was resolved in the ES, however in the motif forum from what I could tell it was never confirmed or denied but my feeling was that only the XS would actually perform as intended.

Sorry if that causes pain, I know it is the reason I will never buy yamaha hardware and only purchase steinberg hosts.

But the midi recording using Motif ES works perfect in FL-Studio.

I’m sure it does and not wanting to commence a new war here, but it’s possibly like the “drag & drop” on drum sampler in pads situation in that as users we find things difficult to understand, ie the reasons why things are like this but it would all come down to implementation bearing in mind that the ES was pre steinberg/yamaha partnering.

One other point though, does it make any difference using Studio Connections?

Just a thought.

I tried using it with and without Studio manager, no difference.

Scientific method – eliminate devices until there is one left, that device is the problem.

Since FL works fine, that’s not the problem. Since FL is on your computer, and it works fine, that is not the problem. Since you used the same cables with FL as you did with Cubase, those are not the problem.

So the problem now is either with Cubase or the Yamaha. Hook up another midi device, see if it has the same timing glitch. If it does, then Cubase is the culprit. If it works fine, then your Motif is messing it up.

EDIT: what version of Cubase are you using?

Did you re-start Cubase after checking Sys. Timestamp or switching to the Emulated Ports? Did you make sure auto quantize was off? What if you don’t start the project at bar 1, but say bar 3 instead?