When will "Tacet" be shown?

Hi! :slight_smile:

I have a player that has nothing to do in one flow.

The flow has one metric change (from 4/4 to 5/4) and a fermata on the last note (in another player’s instrument).
Only when I delete the metric change AND the fermata, the player’s part show “Tacet” for this flow.
What can I do?

(The score must always show all players, so I can’t simply remove this flow from the player…)

If you really need to have the empty staves in the Full Score, then you could create another Player, which only exists in the Tacet flows in the Score.

Hi, @benwiggy!

Thanks for your reply - I was half afraid that this would be the solution currently :wink:
I will have a talk with the composer. Maybe showing all the players only on page 1 would be an option.

@ Dorico Team:
Please file this as a feature request (or maybe a bug report). A player with nothing to do should get his Tacet event if there are fermatas and metric changes somewhere :wink:

Thanks! :slight_smile:

A player who is not assigned to a flow will show just “TACET” text. However, this player’s staves will therefore not appear in the full score.

It has been requested before to have more options relating to tacet players in multi-movement works where you want to continue showing the same number of staves in the score, but reduce the amount shown in parts for tacet movements.

I’ve done this 2 ways before:

  1. If a player is tacet for an entire project, but needs to appear in the score, it’s easy to simply apply a “tacet” page template that doesn’t include a music frame.

  2. If tacet for only one flow, you can create a Paragraph Style with a white Background Color that will hide any music. In Engrave force the entire flow on to one system (I’m at 370% here), enter a bunch of spaces as Text that use the Paragraph Style you created, then apply text that creates the Tacet. Switch to Local and hide the text in the score. In the example below you can see that there are no page overrides, yet I have a tacet for Flow 3.


Just came across the problem. Ended up creating a rectangular PDF with TACET in the middle and importing it into a Graphics frame. After scrunching up the flow as Todd suggests, it’s easy to obscure it with a Graphics frame. I found the paragraph style solution somehow still let the rehearsal marks bleed through. It will be useful (when it arrives) to have a TACET override so that you can still keep a player/instrument in the full score while having TACET in the part.

I’m not at my computer to check, but I think you can select the rehearsal marks and blast them off the page in Engrave so they won’t show.