Where are the Patchname Scripts on Mac for Cubase 6?


I’m running Cubase 6.5.4 on Macbook.

Where do I put the patchname scripts?

I used to use Cubase LE on this computer, which had come with a piece of hardware I had bought. When I did an upgrade to my computer, Cubase LE stopped working, which is when I decided to buy the full version.

When I was using Cubase LE, the patchname scripts were in :

Cubase LE > Library > Midi Device Patchname Scripts > inactive > Yamaha

The folder “inactive” contains different folders for each brand, & inside these folders are .txt files which are the scripts for each different model. I remember, mine (Yamaha S90) wasn’t originally there, so I had to find it & drop it in the folder & it then started working… but this was on Cubase LE.

I’m running Cubase 6.5.4 now.

All I have is the application icon “Cubase” in my Applications folder. There is no Cubase folder anywhere. The old “Cubase LE” folder still exists, but my new Cubase doesn’t see it.)

Where are the Patchname Scripts on Mac for Cubase 6?


I had to call Apple to find this out when I bought my 1st Mac.
In the Finder, click and hold “GO” at the top of the screen, and at the same time press “option” key. The “Library” appears in the menu.
The path should be Library> CUBASE 6> Scripts> Patchnames> Inactive> …

I have OS X 10.8.2
Good luck

I have OS X 10.6.8
I just did an update, that’s the most I’m getting.
I tried what you said on my friend’s Macbook Pro (newer, probably has 10.8 on it, forgot to check) & it worked, just like you said… gave access to the “Library”

Mine however (10.6.8) doesn’t do that. In Finder, when I click & hold “Go”, then press “option”, it doesn’t change anything. The little symbol (which represents that key, I suppose) appears next to the “Enclosing Folder” option, but nothing changes at all… definitely no Library.

What I DID do is, I created the exact path you specified, starting from the Library folder (situated in my home folder), & put the scripts in there, but Cubase still doesn’t see it.

Next thing I think I’m going to do is delete everything related to Cubase in my computer, including everything related to the old version of Cubase LE I have installed (which doesn’t work anymore) & try reinstalling my Cubase 6.5.4 from scratch. Hopefully this will resolve all issues & NOT CREATE NEW ISSUES which will cause me to pull my hair out…

:S Wish me luck!!

OK, I got rid of both Cubase LE, & Cubase & re-installed from scratch. Looks like it created the right folder in the Library the way it should, the path is:

Mac HD > Users > (my computer name) > Library > Application Support > Steinberg > Cubase 6 > Scripts > Patchnames > inactive > yamaha

This folder contains .txt files corresponding to various yamaha models. S90 is in there. Great!

However, in Cubase, I used to be able (on Cubase LE) to select the sound I wanted in a dropdown menu which was situated, in the Left-most vertical column of the given channel, right underneath the “Midi Input”, “Midi Output” & Midi Channel #… now, instead, there is a numerical “Bank Selector” parameter & a “Program Selector” parameter… which is not sufficient because each bank (PRE1, PRE2, PRE3, GM, User) is supposed to have both an MSB & LSB number (so a single “Bank Selector” parameter is not enough)

& besides, I know the SCRIPTS are there, I know I’m supposed to have access to them, I used to be able to do this in a much lower & older version of Cubase… so how do I do it now?

I’m using:
OS-X 10.6.8
Cubase 6.5.4

When I go to “Midi Device Manager” and:

  • click “Install Device”, I get a pop-up menu entitled “Scripts”, it is EMPTY & there is only an option to “Define new”, which when clicked opens a “Create New MIDI Device” window which I have NO CLUE what to do with…
  • click “Open Device”, it does NOTHING at all.
  • click “Import Setup”, it opens a browser window, but when I navigate to the folder in question (see path above), all the .txt files are not available to be chosen (like they’re not the right format).

I am extremely exasperated with this problem… once I figure this out, I should (theoretically) be up & running, but this is proving to be a great damper in my ability to use this program properly…

PLEASE HELP…! :frowning:(

It works here, but I’m using a PC. On the PC the Scripts folder is in the same place as the main Cubase preferences.

According to this http://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/removing-the-preferences-of-the-sequencer/kb_back/2025.html, your preferences (and Scripts, I think) should be placed here:

Users/Your Username/Library/Preferences/Cubase 6

If the Scripts folder isn’t there, try copying it in.

BTW, this is all mentioned in the Custumizing chapter (p. 539) of the manual (Help menu->Documentation->Operation Manual).
To learn about MIDI devices: Help menu->Documentation->Midi Devices.


thanks for the replies guys!

I got it!

Like you said, the Scripts folder was actually not there, so I just created one & it works!