Where is the Click?

I can’t hear the metronome in Cubase 9.5
I press C and nothing happens.
I click the metronome icon and nothing happens. I hear nothing whens it’s lit or turned off.
I am trying my absolute upmost to remain calm but underneath I am SOOOOOOO angry.

Check your vst connections, on the outputs you have checkboxes for the click. Don’t remember where this setting is if you’re using “control room”.

If that’s not the case you might have the metronome in midi mode with no midi target.

Nope nothings working.
How hard is it to not mess up a metronome. I’ve never ever had trouble with it before.

Do you use Control Room?

More info about your routing would be helpful.

I’m having the same problem. No metronome. No idea why.


Could you describe your settings and routing, please?

Did we sort this out ? I have the same no click

Could you describe (best to send screenshots) your settings and routing, please?

…and Cubase version. The metronome changed in 9.5.

Yes, we did.

OK Thanks Guys I,m running the projects from the Control Room and i now have the click. This is Cubase 9.5 that i have just bought.