Where should VST2 plugins be located?

I’ve read the thread on which VST2 plugins will work with Dorico, and found the GUID numbers for the two that I own and would like to use in Dorico, EWQL’s Play and Garritan’s Aria Player.

I’ve edited the vst2whitelist.txt file to add the name and GUID as listed in the thread.

But no matter where I’ve copied the plugins to, they’re still not recognized in Dorico when I go to the Play mode and click on the list of instruments.

Where should I copy the vst2 plugins in order for Dorico to recognize and use them?

Thanks.

Win: C:\Program Files\Common Files\VST2
OSX: /Library/Audio/Plug-Ins/VST

In the future (not exactly sure if already in the first update) we will add the possibility to add custom search paths for VST2 plugs.

@dhbailey52
Also realize that there are multiple default.xml files to check: the original is (IIRC) in one of the Programs > Steinberg subfolders; the other is in your user > appData > Roaming > Steinberg > VST Audio Engine folder

Thanks for the help Ulf and Derek.

I’ve copied the two .dlls, one for Aria Player and one for the EWQL Play into the folder Ulf listed.
I can find the whitelist.txt file, which I had previously edited to include the two names and GUID numbers.
I can only find one defaults.xml file with the long list of GUID numbers – I’ve added two lines, copied two existing lines and simply copied/pasted the GUID numbers for these two VST2 plugins into those lines. They both end in 1.

When I run Dorico I still only see the original VST3 plugins which installed with Dorico and don’t see these two additional ones.

What am I missing?

I do find a “Vst2xPlugin Blacklist VSTAudioEngine.xml” which specifically lists the directory that Ulf told me to copy the VST2 dll files into. In my experience, anything called “blacklist” is telling something/somebody not to do something. Is this file blocking my installation’s ability to find the two dll files I want to use?

Once you get the VST Players (Aria) available, you should be able to find them in the Play mode.
playMode.png

I know where they should be but even though I’ve followed every step that people have outlined, using the GUID numbers as people have listed in the other thread and copied the two VST2 dll files to the VST2 folder as instructed, neither the Aria Player nor the EWQL Play VSTs are showing up.

So I’m zipping up my defaults.xml and my vst2whitelist.txt files and posting them here to see if anybody can figure out what I’m doing wrong.
Bailey VST2 files.zip (5.08 KB)
Thank you for helping me! I should be able to figure this out better. Oh well . . .

You need to remove the blank lines in the whitelist file.

Thank you! That got the Aria Player to show up but the play_VST_x64 (the EWQL Play VST) still isn’t showing up.

I’ve removed all the blank lines, even the one following the play_VST_x64 entry. I copied the GUID directly out of the other thread. But at least I’m making progress.

Thanks!

So the next thing I’d check is the following:

  1. Make sure you spelled the VST name exactly as in the file name (without the .vst extension). No extra spaces.
  2. Check that the GUID you used in the whitelist file is in your defaults.xml file once and only once in the list of GUID section.

Otherwise, I don’t know what to tell you.

I’ll check that out tomorrow – I really appreciate your help with this. I’m sure it’s a clerical error I’ve made but I’m darned if I can figure out what.

Thanks.

How do you find out which GUIDs correspond to which VST plug-in numbers (ex: ) in the Defaults.xml file? I want to add my VST2 plug-ins to the vst2whitelist.txt file, but cannot, since I do not know which programs each GUID belongs to. Is there a list online? Or is there a way to find out within each individual VST2 program? Thanks in advance for any help with this!

Actually, the GUID is not needed anymore, you can put in any number you like.

In our initial design a comparison of both, name and GUID was done, but we drove into some conceptual problems with that. So now the GUID check is omitted, though still some arbitrary entry in the whitelist is necessary.
But important is still the correct name. The name must match the VSTi’s bundle/dll name without the extension.

Thank you for the info, Ulf! It is working for my VST2’s, however, Kontakt 5 is not appearing in Dorico. Whether I use the original GUID or a fabricated one, or try listing it as either Kontakt 5 or Kontakt 5 16 out–it is absent from the playback options. What do you recommend for a solution? Thanks!

Please zip me up your folder C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine_64 plus your whitelist and I’ll have a look.

There is not a folder named AppData contained in my username folder. Neither could I find that folder, nor Roaming, nor Steinberg when searching for them in a Finder window (although I did locate the folder Steinberg Dorico in my search, but it was in my downloads folder and it contained none of the sub-folders in the path you gave. I assume this is the program folder I downloaded after purchasing the program). I searched the folder path online, and it seems like it pertains to Windows. If this is the case, is there an equivalent path on a Mac?

I did, however, find a file named VSTAudioEngine found in C:\Applications\Dorico\Contents\Applications, but it is 60MB when zipped, and this page only allows for uploads of up to 2MB, so I am unable to attach it. I have zipped and attached vst2whitelist.txt to this message. Please let me know if there is another way to find the VSTAudioEngine_64 file (or equivalent) on my Mac, and I will send it. Thanks again for your help!
vst2whitelist.txt.zip (1.11 KB)

Have you set your system to “Show Hidden Files” (Control Panel > Folder Options > View Tab) ?

The VSTAudioEngine folder is found inside /Users/your-user-name/Library/Preferences on Mac.

Derrek, thank you for the info, but in searching your suggestion online, I found that the method you mentioned pertains only to Windows. I am using a Mac, not a PC. Doing another online search, I found a source that said hidden files may be viewed on a Mac by inputting the following into the Terminal application (hitting the Return key after each line):

defaults write com.apple.finder AppleShowAllFiles YES
killall Finder

I did this, and now I can see more files (hidden ones being a little opaque), but I still do not see the AppData folder in my username folder. As stated in my previous post, AppData seems to be Windows-type folder, unless I am missing something. If I am missing something, please let me know what I can do to find the VSTEngineAudio_64 file (or Mac equivalent) that Ulf asked me to send him. Thanks!

Thanks, Daniel! Attached is a zipped copy of the file (if this is what you are requesting, Ulf. If not, please let me know which other file I should send).
VSTAudioEngine.zip (358 KB)

Yes, that’s the one. I’m not in the office today, so I will have a look tomorrow.