Whoa! What is this? No MP3 import in WLE9?

This is weird. Can I not import an MP3 straight into WLE9? I see there is no conversion happening but I thought this was possible? I am sure I actually did this but now I cannot. Haha, am I losing it? :confused:

I am importing the MP3 by using the ‘File’ tab at the top of the project window. I think the manual says that I can do this? And actually, I can drag and drop it (an MP3) into the project and everything is fine. But why can’t I use the import function?

did you looked in the preferences? or maybe your current project, is only configured to work with wav-files?

Thanks for the response, raz, but this would be a fresh project window. And bear in mind, I can drag and drop an MP3 into the project without a problem, it is just when I click on the ‘File’ tab and try to import from there. I don’t know why this is happening… :confused: I can import a CD track for that matter without a problem, but the MP3 track is complete noise, with a full expanse of the wave filling the track window.

yes, but maybe you can handle some options in the preferences, which are related to every new project you make. with that in mind, it could be that the system basically don´t or can´t let mp3-files into wavelab through the main-regular path. it´s possible when you just drag n drop a mp3-file into the interface of wavelab, the system is bypass it´s own setting( as result of an program issue) and let the mp3 normally in.

Given a mp3 file with a problem, try to rename it. This, to maybe avoid a conflict with the cache system of WLE 8, in case you upgraded from 8.

PG, I did upgrade from 8 but I have also uninstalled WL8 months ago - when I upgraded to WL9 - and now I have uninstalled and reinstalled WL9.0.25. Nothing changes.

In regards to the cache process, I’m not understanding your idea. I am trying to import MP3s unique to WL, not the same ones I imported in WL8. Are you still wanting me to pursue this? Are you suggesting simply changing the title of the track or modifying the MP3 signature?

Here’s some pics. The MP3 ‘Side Tracked’ was import via the File tab and then ‘Kidney Stew’ was dragged and dropped. Also note that when I do the File tab import, WL9 deposits a GPK file in my album list. Why should this be happening? I don’t think this is a good thing at all.

Find this path:

Now, quit WaveLab and erase everything in this folder.
Load WaveLab again: do you still have the problem?

Yes, the behavior hasn’t changed.

OK, so here’s a twist, PG. If I close WL after importing an MP3 that will not play - and then open WL again, the Decoder window pops up onscreen and decodes the bad track and then it will play properly. Strange. Please note too, as I said before, the Decoder is not being used on the import function but it does come up on the drag and drop process.

The origin of your mistake, I think:
To open a file in WaveLab, use the Open function, simply.
The import function is to open unknown file formats. This is rarely used.

PG, no, this does not work. When you locate the album on a HD, the album title will show up, but when you click on the album you will find there are no tracks there to open - the album displays no tracks.

But wait a minute? Are you suggesting that the import option is not for importing music from a HD? Is it only for importing tracks off CDs? This seems a little odd to me. Knowing that drag and drop initiates the converter, and then opening a corrupted file (a non-converted MP3) in a WL project for the second time WILL initiate the converter… Well, something is wrong. This is not typical behavior in a DAW program. The file should never load if it’s not converted, right? It can’t be played or worked on. Don’t you agree it is strange behavior that WL will convert the loaded non-converted MP3 when I close the progarm and then reopen it?

I would like to know if we speak about the same thing… please show me a picture of the procedure you use to “import” a file.

This is probably due to the filter in the file selector which is not always showing all types of audio files. I’ve noticed a couple of times (don’t know when it started) that WL reverts back to showing only .wav, .aiff etcetera, leaving out many other types. Simply set it to ‘All known audio file types’ or similar wording.

Arjan, you are right about this, when ‘all files’ is selected in the ‘Browse’ window that results from the ‘Open’ process, WL will load, open, convert and play an MP3. Seems very simple, no files left behind and this is what PG had in mind, I get it.

I will conclude that the import tab is strictly for importing CD tracks.

Arjan, Q: I have a designated HD for my DAW work and I have set up my cache and WL files to be stored there, however, I wonder if I should move the ‘Companion’ folder there as well to avoid bogging my C drive and to keep things under one roof. What are you doing with your files?

Mmh, AFAIK I don’t have a separate Companion folder. I guess you set that up to avoid .mkr and .gpk files to be written in your audio folders? In that case, I’d certainly advise to move the Companion folder away from the OS drive.

I simply have everything written in the same folder so when backing up everything is together where maybe much later on they’ll meet up again in WL 21.5 :sunglasses: . It does fill up a directory quite quickly but I usually select files from within WL anyway, where those files don’t show…

I had the same problem. This was a great help. Thanks.