Whole rests - what's happening here?

Hi all! So I guess I don’t understand exactly what the Layout Options checkbox for “show rests in empty bars” does. Here’s a screenshot of a sample part I’m working on:

As you can see “show rests in empty bars” is not selected for this organ part so the treble clef staff will primarily be blank above chord changes. In general, this is what I want. I’m not sure why the rests are suddenly showing in m284-5 though. Is it due to the tempo marking? I’m not complaining, I want to to see the rests here, I just don’t understand how to force them to appear. On the other hand, in m287 the other organist (it’s an organ battle featuring Lucas Brown and Joey DeFrancesco) has a cadenza so I need to show the rests in that bar. How to I force them to show?

If I can’t force the rests to show in m287, I guess I need to take the opposite approach, show all rests, and then hide the vast majority of them. In Finale I would have just used a “blank notation” staff style. What’s the best practice to accomplish this in Dorico? Whole rests don’t seem to be scalable, and changing the color slightly affects the line that the rest hangs from so that’s not gonna work. Entering two half rests, setting the scale to 1% seems to make them vanish so that would be a possibility. How do you accomplish the blank notation style, while still allowing some whole rests to be seen? Obviously there is some sort of trigger to have them show or they wouldn’t be showing in m284-5 in my example. I just can’t quite figure it out.


Fred, select the last rest. Is the “Ends voice” property set in the Properties Panel?

If so, toggle it off, and the bar rests should reappear.

The last one under the poco rit? I don’t see that property even available. Am I looking in the right place?

ends voice.png

Ah, here’s a clue though - when I select that rest the “Multi-bar rest” property is available. Maybe because it’s 2 measures that would normally be combined into a multibar rest, Dorico shows them, then when they are split due to the tempo marking they still show as whole rests?

Switch to Write mode. Sorry, should have mentioned that above.

In Write mode, I don’t even have that option here. If I click the half rest in the bar before then that option shows as normal. I’m guessing Dorico is doing the calculation that this should be a multibar rest first, then specifying that it should show (obviously), and only then calculating the split for the tempo, but the specification that it should show is still present. Otherwise I don’t know why I would be getting multibar rest properties for a whole rest.

If the whole rests are only showing due to a weird situational quirk (bug?) and there’s no way to override having the “show rests in empty bars” setting not checked, I guess I will take the opposite approach: show all rests and hide as needed.

What’s the best way to accomplish the “blank notation” style? The two half rests and scale to 1% approach I tried? Or is there a better way? There’s not a way to change an individual rest glyph to just nothing or an empty slot in the font code is there?

Parts are due today, so I just gotta get them done at this point, regardless if it’s the most efficient way.

The option for showing bar rests in empty bars in Layout Options does indeed not apply to those bars Dorico considers to be multi-bar rests.

So the fact they are showing is just an odd situational quirk here, right? The specific case being 2 whole rests that would normally be combined into a multibar rest, but are split by the tempo text. There’s no way to force the rests to show in m287 for example?

You can’t force bars together into a multi-bar rest if there’s something that’s splitting them, no.

I guess I have two issues here. Obviously I can’t force a multibar rest if something is splitting it, but the first issue is why are the whole rests showing if I don’t have “show bar rests in empty bars” selected? I think we’ve concluded this is a bug due to this specific situation, as it’s easy for me to reproduce now that I understand it. Here’s another example where I recreated it in an empty file:

^^^ “Show bar rests in enpty bars” is obviously not selected, yet Dorico is showing the rests anyway for those two measures.

The second issue is sort of a two-part question, whether there is any manual override to the “show bar rests” setting, and if not what’s the best practice to obtain both “blank notation” and whole rests in the same file?

EDIT: oops, just realized I had the score layout selected when I did the screenshot, but it’s the same setting and result in the part.

To your first issue: it’s not a bug, it’s working as designed. Whether you like it or not, single bar rests are still treated as multi-rests in parts where rests are allowed to be consolidated into multi-rests.

I’m not sure of an easy way around this, I’m afraid.

John Barron pointed out that my original query about removing rests is solved with … Remove Rests, d’oh!

Possibly related, probably not, but maybe ok to avoid starting a whole new thread.

I have created an independent time signature in some parts. Previous bar equals next bar.

To make this happen correctly (sort of), I re-enter the old time signature in the bar after the time signature change, and hide the time signature (which can be seen in the signposts).

But I want the two bars at rehearsal number 31 to show as a multi-bar rest. Can’t make it happen! I tried to re-enter the 3/4 time signature in the third bar of 31 and then hiding it. No multi-bar. I tried entering rests, with forced duration and Y. Didn’t work.

The time signature change has to stay where it is, to make it easier for the player to navigate naturally to the surrounding player and the character of the phrases and sections of the music.

Ideas much appreciated.
Skjermbilde 2019-10-11 kl. 13.22.55.png

Isn’t the first cut common bar there half a beat short of its proper duration?

Yes. What I have done:

Select the stave in question > shift+M > cutc, 1.5 > alt+enter.

Next bar: shift+M > 3/4 > alt+enter.

Everything notated as quadruplets, hiding brackets and numbers.

Reminder in this case: the cut common bar is entered as described above because it has to align with 3/4 bars in other players.

I am completely open for operations I have missed here.

Just wondering : have you tried shift-B, “rest” without the quotes? This is how you input bar rests manually in Dorico (and you can use the button in the right panel too, but I never do)

And isn’t that particularly weird since the signposts confirm there are two half notes in cut common time in that very bar, and three quarter notes in the next?

Thanks, will try and report back!