Whoops - tried to troubleshoot audio playback and busted Dorico

Sorry for long post.

I couldn’t get Dorico to play chord symbols back to me (the chart had no notation, only chord symbols). Unfortunately I started the process below before opening a project with regular piano notation to see if that type of playback worked.

I use a Steinberg UR12 interface and all my audio (Cubase, browser audio, Youtube etc) comes through the UR12.

I opened Device Control Panel and tried to choose the UR12 as the output device but It wasn’t present in the menu. I saw the Steinberg ASIO driver in the drop down but when I went to choose it, a box just flashed at me and I couldn’t get the change to stick. I found a post here that suggested unchecking ‘Allow ASIO host application to take exclusive control of selected port configuration’. I really didn’t want to break my Cubase setup but I went ahead. Suddenly the UR12 appeared in the Output Port list! Great. So I checked that and tried chord playback again, no luck. I then saw the UR12 in the list of Input Ports. It felt wrong but I checked that as well. Nothing.

Then I went to the Youtube video which explains how to troubleshoot playback issues. I discovered that Dorico is indeed outputting audio through the UR12 because when I open an instance of HALion SE, and the editor box pops up, I can drag my mouse across the keyboard and hear sound.

The Youtube video then suggests that sometimes I have to go into my App Data folder in Windows and delete VSTAudioEngine_64. It says to exit Dorico then restart.

But in the meantime I decided to check to see if Dorico was working when I ask it to play back a piano track. And here’s where my problems start. I closed Dorico and tried to relaunch it. It didn’t seem to work. Then I tried again and the launch process hung with an error message in the splash screen that said ‘Audio process died’ or something similar. So I ended the task and tried again… and this time Dorico launched!!

So with Dorico launched I tried to play a regular piano score and sure enough it works. There are chord symbols in this project too and they’re not playing back but playback is working for notes.

The problem now is - what in the heck was that weird event when the launch hung and I got the message that ‘Audio engine died’? Obviously this is user error.

I have just purchased Dorico with the discount (and I’m so excited about making the big switch from Finale). I am waiting for verification of my Finale install. Should I just wait and then uninstall the program and reinstall? That weird behaviour scared me because Dorico was totally stable until I tried all of this.

Another thing I should mention is that when I installed the trial version I didn’t install either of the large sound libraries because I wanted to see if my existing install of HALion sounds for Cubase would automatically be ‘seen’ by Dorico.

Dear mset,
Regarding your problem to make chords track play, your last paragraph says it all…
You need to assign a vsti to this track, in play mode (opening the player’s card). If no vsti is properly installed, no wonder it does not work!
All the other problems are unrelated imho. You should start with the video about Troubleshooting audio : https://m.youtube.com/watch?v=5BcPJd92zqU

Hi Marc and thanks for the reply. I’m sorry I didn’t make this clearer. I have already assigned a VSTI to the track - I am choosing Acoustic Grand Piano for the Chords track and I have clicked the blue Speaker icon. When I click Edit Instrument the HALion editor pops up and I can hear the grand piano when I click the virtual piano keys. I’m pretty sure Dorico knows I have the HALion sounds available from my Cubase install.

I’m not quite sure what you mean by ‘Opening the Player’s card’. I initiated this chord test project by adding a Guitar Player and then I added chord symbols. When I click on the Play tab at the top, I see Flow 1 and below that are Time and Chords. If I click the drop down arrow beside Chords I can see the little keyboard icon that I know from Cubase, which is the VST instrument editor/chooser. I have clicked that and it’s blue. Then below that is the player called Guitar. Please note - I can hear the metronome just fine.

But really I am not so concerned about this right now. What matters to me is why did Dorico hang on startup and show me that weird message in the splash screen ‘Audio Engine died’? Have I messed up the install and should I want for my purchase to clear and then start again from the beginning?

With the UR12 you should not use the Generic Low Latency Driver but instead the “Yamaha Steinberg USB ASIO” driver. If that one does not turn up in the list of available ASIO drivers in Dorico, then try reinstalling the driver. You can download it again here: https://www.steinberg.net/index.php?id=downloads_ur12&L=0

No, just get the right driver going and you will be fine.

Yes, Dorico will also pick up stuff that is already installed via Cubase. But you can still let the Dorico installers run, as they maybe update e.g. HALion Sonic SE to a newer version. And HALion Symphonic Orchestra you probably also want to get installed sooner or later, because orchestral playback just sounds so much better with it.

To expand on Ulf’s point, you don’t need to worry that running Dorico’s playback installers will leave you with multiple redundant copies of the suonds on your computer: the installer is clever enough to find and update the existing sounds wherever they happen to be located on your computer.

Ulf, thanks a lot for taking the time to respond.

Something strange is going on. As I mentioned earlier, I was seeing the Steinberg USB ASIO driver in the drop down menu for ASIO Driver. It was there, but I could not choose it - when I clicked on it, a dialog box would pop up very briefly (I couldn’t even see what it said) and then it would disappear. The Generic Driver would still be listed. I tried this several times. As I mentioned, I had to unclick something to get the UR12 to appear in the list of available Output Devices.

Anyway, to my great surprise, just now I went back, opened Device Setup, and tried again. This time it worked! I have no idea why it suddenly worked. So now my ASIO driver is the Yamaha Steinberg USB ASIO, and the Stereo Output is going to the UR12. In addition, now when I click on the Device Control Panel, I am getting a different looking box than before. This one is definitely for the Steinberg driver.

However… I still cannot get the chords to play back. As I mentioned, piano playback is working fine, as is bass guitar, and I assume that any instrument I chose would work.

So all this is fine, but why is Dorico reacting so variably? Can you tell me what that message was that I saw, when I tried to open Dorico and the splash screen froze with the words ‘Audio Engine died’ or whatever it was, it was’ Audio ____ died’ for sure.

I really feel like I must have broken something because Dorico was acting totally stable from the moment I installed it until tonight when I started playing with these audio settings and now suddenly it hangs on launch and also does what I just mentioned (I’m unable to do something then suddenly able to do it later on).

Any ideas?

Daniel, thanks for weighing in here. By the way, I grabbed a Dorico license tonight. Just waiting for my Finale crossgrade to get verified. I’m making the switch!

But the weirdness is concerning me a bit. Dorico is acting unusual. Can you say why I got that weird hang on launch with that message in the splash screen saying ‘Audio _____ died’? Also I wonder why I couldn’t choose the Steinberg USB ASIO driver before but now suddenly I can?

Let me be perfectly clear - I don’t think this has anything to do with Dorico, I think it has something to do with me busting something by messing with the settings somehow? Either that or there’s something about the way my audio hardware is configured that’s messing Dorico up. But again, it was rock solid until tonight when I started playing with these audio settings.

If you tell me not to worry about this stuff, I won’t : )

I’ll figure out why my chords aren’t playing back on my own.

PS - Verification successful. Woohoo! I’m officially switched from Finale to Dorico.

Small Eureka. I got the chord playback working!

If you encounter an issue like the program hanging on start-up and it telling you that the audio engine died, obviously it’s not ideal, but it’s not a disastrous situation. The simplest and quickest way out of the situation is simply to reboot your computer: that will ensure that any lingering processes that are fouling things up will be cleaned up, and Dorico will then restart cleanly. You can also go poking around in Task Manager to find processes to kill off, but I think it’s simpler just to restart the program.

In any case, provided you have the Yamaha USB ASIO driver chosen, and you’re getting sound in general from Dorico, then you don’t need to poke around with the settings any further and any issues you might have with things like chord symbols not playing back will be issues with features of the software rather than your audio setup.

Okay thanks Daniel. I got the chord playback working.

Last question if you get a chance to answer - I installed the demo version of Dorico without asking the installer to download either of the two sound banks. Now I have purchased a license; is the best way forward to uninstall the program and start from scratch or is this not necessary?

Then, I assume that once I have authenticated my install, I can use the downloader to retrieve the orchestral sound banks. I will probably do the HALion banks too since mine are probably old.

No, you don’t need to uninstall and reinstall anything. The trial installer is the main installer. If you haven’t yet run the “Dorico Playback 1” and “Dorico Playback 2” installers, you can indeed download and run these from Steinberg Download Assistant, but you don’t need to do anything to the installation of Dorico itself.