Why am I not allowed to have the Cubase installer? It's ridiculous. I'm about to leave Cubase

I paid for the full version of Cubase 9. I uninstalled it and tried to reinstall because of an issue customer support would not help me with. Now, I cannot reinstall because when I enter the code in the website, it gives some random error on the perfectly legitimate product I paid for. I contacted customer service and they want me to give remote access to somebody. This is completely unacceptable. I will not allow a random person to remote to my computer because their website give me errors when I try to DOWNLOAD THE PRODUCT I PAID FOR.

If this isn’t resolved within a week I’m leaving Cubase and I’m not going to buy another update. It’s unbelievable that a product north of $400 won’t even install on my computer. Reaper costs $60 and doesn’t require an extra dongle. Fix the issue with my code or I will share this problem on social media to warn people about the absolute garbage treatment from Steinberg. This is costing me time and money and there are too many competitive options to stay with Cubase.

Ridiculous is wasting your time and brain power making a post that seems to have no purpose besides making you look like someone really unpleasant to deal with.

How about actually explaining what’s going on so someone can try to help you? What code? What error? What issue were you having?

You DON’T need a code to redownload Cubase. You just have to log into your MySteinberg, using the login information that you set.

Tell me, how are they treating you like garbage when it’s YOU who’s refusing to receive support?

I login to MySteinberg and type in the product key and it tells me “This Download Access Code does not exist. - 404” So after contacting customer support and waiting a week and a half for a response they want to remote into my computer. I have personal information on this computer and that’s simply out of the question. The code should not have an error to download the installer. My eLicenser, which is still installed, does show I have Cubase 9 activated so there is no reason the code should provide an error.

I waited 48 hours for a response, and it took over a week for a response. It seems Steinberg is wasting my time not the other way around.

You don’t need a download access code. Login to MySteinberg, click on support, scroll down a little and click downloads, select your Cubase version, that’s it pretty easy.

Under “My Products” there is nothing there, it’s blank. No reference to Cubase 9 which I already installed using the same process, nor the eLicenser which I currently have installed showing my Cubase 9 access. Under support-> downloads, I can only download the patch. It refers back to “My Products,” which of course, is blank.

Let me also restate, I have replied to customer service again with no response. “Your current e-mail issue is already in our support queue to be answered. However, you may wish to visit our online Knowledge Base (http://4wrd.it/STBKNOWLEDGE) and Forum (http://4wrd.it/STBFORUM). These are helpful resources with quick answers to common questions, available 24 hours a day, 7 day a week.”

The email specifically states I to post here as a helpful resource. What am I left to do? If I don’t have a solution within a few days I’m switching to Reaper.

Under downloads you select the drop down menu under download software and select your Cubase version. Under the Mac and Windows buttons for downloading the latest patch, there is a link to download Steinberg Download Assistant, which you need for downloading newer Cubase versions.

Another thing, if it doesn’t display anything under MyProducts, it’s because you haven’t registered your license with your MySteinberg account

Blank. It used to have a drop down, that’s how I downloaded the software in the first place. I appreciate the Cubase community trying to help, but this should be solved by Steinberg.

https://i.imgur.com/drCEab9.png

If you haven’t registered the Elicenser key, the system doesn’t know what is on it. Which is what these helpful forum members are trying to tell you.

Also, I don’t mean to offend, but there’s complete documentation on how it works in the SB Knowledgebase, if you read it you can gain a complete understanding of the process.

Latest version on Steinberg: 6.10.6.2223

I have the latest version and cannot activate…until I download the latest version
https://i.imgur.com/EHqj0BB.png

I feel like I’m running in circles. Steve, I am not offended in any way I am just looking for a solution. I already read the support pages on Steinberg before I emailed customer support. I agree with you, the forum members here are being helpful and responsive which is a big plus. But let’s be honest here, the competition for Cubase costs way less and does not require an extra dongle. And it certainly doesn’t require me to spend time trying to fix issues like this which shouldn’t take a week and a half for customer service to respond.

You are not reading my reply dude…

Go to SUPPORT on the top menu, scroll down and then click the download button

Im pretty sure the guys at Steinberg have better things to do than replying questions that can easily be found on the support page.



Just for the last picture

So what is displayed under the Elicenser tab?

problem was finally solved, thank you all for helping.

Do tell, for other users. How was it solved?

Probably in the way you guys kept trying to tell him. :rofl:

Glad you got it sorted but as Steve says, it might be useful for folk with similar issues in future to know how it was solved…