Why can't the Cubase Pool use the Project Tempo as the default tempo for newly recorded Audio parts?

I must have been doing something wrong since forever because I can’t for the life of me figure out why the Cubase Pool can’t use the Project Tempo as the default tempo for newly recorded Audio parts?
So if I have a song with some part and the Project Tempo is set to 180BPM I sometimes like to write parts at 120BPM as it’s more comfortable while writing before I have the chance to practice the parts.
Now I naturally need to check back and forth to make sure it sounds like I hear it in my head at full tempo so I need musical mode to work properly which it doesn’t if the tempi are off.

Since Cubase LE and Cubase SX3/C4 I’ve been annoyed with this behavior and I really hope it’s me who’s done it all wrong all the time.
What is the reason that the correct tempo is calculated as long as I stop the recording inside the cycle but as soon as I run over the edge at the right Locator the Tempo is set wrong?
Wrong in this case means “???” like Cubase can’t figure out what Tempo the recording it just performed was made at, or higher value to compensate for a longer recording (I think?).

What’s the big deal with this? Well, if I happen to want to fiddle with the tempo I have to figure out which tempi are set correct, which are set wrong and which are not set at all.
Then I have to manually set them to something that works, and It’s not as simple as all “???”-files are the same either if they are recorded with the Project Tempo set to different values.
So I have to sooner or later take a break and get out of “T H E * Z O N E” to fiddle with that.
Maybe there is a good explanation for this and one man’s feature is another man’s bug and all that but I’m kind of sick and tired of it !!!

Can anyone confirm this?

Or is it time for a feature request for something like this … in 2019 ???

hmm I don’t have this problem. No matter if I record inside or outside the cycle, the audio file in the pool will show exactly the project tempo I used during the recording of the audio.
(I tested with 44,1kHz / 32bit float in C10.0.30 / MacOs)

THAT … :open_mouth: … was the answer I didn’t like haha!
So it works on some systems but not on mine.
Worst case scenario.
You’re on Mac.
I wonder if it works on another PC :question:
Well, now we know that …

Thanks for your time! :sunglasses:

Set your track default to Musical Mode

It is, and I just about never use the … whatever the other one is called. :laughing:

I think its always been flakey - I often have audio files recorded in a session that don’t have their tempo’s correctly entered.

I’ve not been bothered enough to sit down and figure out exactly what causes it, but I think its to do with dropping into record from play (as opposed to initiating record from being stopped) AND having the Cycle on.

I never do that, which means an insignificant number of times.
Always with a count in, and sometimes with a preroll and punch in.
I have to test the preroll/punchin thingie every time I try it to see if it works haha so I should probably do that more often.

Soo … my issue is something else I guess.

Thanks for all the input so far! :sunglasses:

If I recall when I open the pool, some are checked in Musical mode and others are not even though the TRACKS are all set to musical from the outset.

It is WONKY at best

Here, recorded audio gets the current tempo in all cases: Tempo Track Active or not, track timebase set to linear or musical.
I also tried to repro

and couldn’t make it happen.

And to ease confusion, or create more :wink: , A track’s Musical Timebase, and an audio file’s Musical Mode settings don’t interact in the way that seems to have been discussed here. One can be on, the other off- or on– or vice versa, nor, can one switch the other on.

It’s just by doing something to or with the file that requires it to be in musical mode that it gets so flagged, or, by importing a file with tempo metadata that Cubase understands.

Steve, I’ve seen loads of audio files that I’ve recorded into cubase that are missing their tempos. I do a lot of band recording so record tons of audio directly into Cubase and see this issue regularly going back years.

One example of where I notice it is when I’m working on something and decide I’d like to try a slight tempo shift to the track. I go into the pool to turn on tempo stretching for all the files in the session, and can see straight away that some audio files have the triple question marks for tempo when they should have the sessions tempo.

I’ve also noticed that when you consolidate / bounce down parts or audio files in the arrange page, they can sometimes not have the tempo written into them as well.


That’s a ditto for me on recorded tracks randomly displaying a tempo other than what the Project has been set to. This behavior has been present in all versions of Cubase (on Mac) as far back as C4. It has happened so many times over the years, that I’ve gotten into the habit of immediately opening the Pool after recording to double check tempo and correcting it where necessary. I think this issue is more widespread than has been reported here in the forum…and I suspect that may be because many users don’t notice it because they aren’t editing audio with features that depend on a matching tempo entry.

One of the reasons this issue isn’t spoken more loudly of is that it kind of works anyway and you CAN sort the files in the Pool and select the “???” and just type in the tempo one and be done with it and at that moment it’s not that bad.
Eventually, you realize that you’re doing it MILLIONS of times and there is no end to it.
Those who have this “feature” are so used to double checking we do it second nature and click and type and click some more THEN change the tempo, instead of trusting Cubase and just change the tempo and the files will follow.
This little extra maneuver sometimes several times per session is not helping you to stay in … “t h e Z o n e”
It would be great to hear from Steinberg if they’re aware of the issue

I did some further tests.

I always get the right tempo in the pool when:

  • Cycle is off
  • Cycle is on and I don’t record more then one audio take on a track (if I stop the recording before the right locator everything is okay)

I always get “???” when:

  • Cycle is on and I record more than one audio take on one track (if the playhead jumps from the right to the left locator during recording). In the pool, these audio files are shown as a folder (if unfolded, you can see the different takes of the audio file)

Looks like a bug to me…
Can someone confirm?

Yes! Exactly what is happening here. Looks like a but to me too.

Great testing! Thanx!

Yes same behavior here, I’m just so used to it, that I open the audio pool and correct the tempo attributes before doing anything tempo related in the project. Also in a 120bpm project, some files will sometimes be slightly off, like 120,03 or 119,98.
Never figured out how and why, and just correct it. Been doing that as long as I can remember.

Yeah this pretty much describes what I see.

When I get some time I’ll try to repro using the repros you guys have given. I have definitely seen this too, just didn’t give it much thought.