Why do so many VSTs get blacklisted

I just found a cool plugin that makes chord editing faster that Cubase (I hope something like this comes in a C update some day) in Captain Chords. Installed it and of course it did not work at all and got sent into the blacklist. This is not the first plugin that I have had blacklisted. I have no problems with VSTs in any of my other DAWs, not even the free cakewalk that i just installed. Why do Cubase have to be so hard on other brands of VSTs? Can you please help them get the stuff to work? As I have understood the have a ticket asking for assistance.

From their own site:

Any plugin that misbehaves during scan will be blacklisted, as they’ll most likely cause crashes when your projects become more complex.

To fix this, all you usually have to do is:

-Update the plugins to the latest version.
-Update the components required by the plugins.
-Apply the updates for your OS. (check Windows Update)

But in this case this plugin doesn’t support Cubase at all, like their FAQ says. It will crash Cubase if you try to use it, and this is a problem that the developers of this VST plugin have to fix.

In this case it’s the VST maker being hard on Cubase - their VST does not support Cubase.

I suggest you take them up on their money back offer and try Cthulhu by XferRecords, and you’ll have saved yourself $40.
Once you have it set up then you can store all the chords you ever need to play back with one digit…

It is NOT a VST plugin… if it NOT supports Cubase IMHO… get your money back (they must have taken som shortcuts).

Steinberg invented the Vst plugins, instruments and its framework… In the case of building on the correct framework, Cubase should be the first DAW to accept any Vst plugin and instruments…

Wel this is just one example. I have had other plugins before that has also worked in my other DAWs but ended up on the blacklist so I stick by the statement that Cubase is very sensitive and blacklists more VSTs than any other DAW I have (I have four btw) and I don’t like this. So I wonder why Cubase is so sensitive. I have been on a few VST makers forum and some of them also say that the technical support for developers from Cubase is slow. Which also seems counter productive if that is true.

BTW I got a refund from Captain right away, but I hope they fix it cause it is an elegant little solution that I sorely miss in Cubase and it has been requested and ignored by the Cubase developers for years so I hold little hope it will turn up in Cubase 10. But if something like this or some basic function “restrict midi note editor to chord track key and scale” comes in the next Cubase update then I will be the first to upgrade.

As for Chthluhu I see where it got its name… the design of it really feels like an alien horror story to me :wink: Tried and detested it.

The problem is NOT on Steinbergs hands… The problem is that there are a world of “half assed” plugin vendors out there NOT following the “rules” of the VST Software Development Kit (SDK) framework…

Too many are trying to get away with too many shortcuts… If someone claiming to make (and sell) Vst plugins, and it is NOT supported by the SDK vendor… well… Enough said :unamused:

Hey ! I’m new to Cubase and I have the same problem. I find it very frustrating since most of the freewares get blacklisted and at this moment I can’t really buy VSTs.
So what is the technical reason behind this ? Is there a way to solve it ? I saw that it accepted only 64bits VSTs so I used a bridger but it gets blacklisted anyway. If there is no solution is it possible to downgrade Cubase ?

I already explained the technical reason for this above. Some plugins cause instability and crashes and people were blaming Cubase for that. These complaints have basically disappeared since the blacklist was introduced. There’s no “default” blacklist, Cubase only blacklists plugins that misbehave during scan.

Which plugins are you trying to use? Are you sure you bridged them correctly?

If you already bought jBridge, make sure that you’re using the latest version:
https://jstuff.wordpress.com/jbridge/beta_updates/

Thanks for your answer !
For example I was trying to use Aethereal, which is an atmospheric synth freeware, but couldn’t make it work.
I’ll try with your version of the bridger.