Why does Cubase not filter MIDI channels independently?

I have songs on a sequencer that I am trying to record in Cubase Elements 7. All of the different MIDI channels from the sequencer are only seen in Cubase as one channel. I set up MIDI tracks in Cubase to capture each channel independently, but all channels come through at once. Also running this multi-channel sequencer through HALion Sonic SE sends all channels to channel 1. Is there some sort of MIDI filter? What am I missing here?

At the top right of the inspector for each midi track you will find a button entitled “Input Transformer”. If you click that and select ‘local’ you can then begin to set up the track to filter out the unwanted midi channels (pass through the correct midi channel).

The “input transformer” will now appear. At the top of this window you can select a preset - “channel filtering” -> “pass channel xxx”. Select the channel you are interested in & all the other uninteresting channels will be ignored for that particular midi track.

After having done all this you must do one more thing. “Enable” the module - this looks like a tab (there’s 4 of them) at top of the tranformer window.

hope this helps :slight_smile:

PS repeat for all midi tracks …
PPS In my opinion this is actually a design flaw (way too convoluted). Cubase should have a channel filter option (1-16) next to the “Midi Input” section of the inspector in my opinion. This would be much better solution.

There’s an easier way: just record the lot onto a single MIDI track, then afterwards select the part on the track and from the MIDI menu, select “Dissolve Part”.

I cannot find this button “Input Transformer” in Cubase Elements 7. Perhaps it is not in this version?

Thank you. This saved me a lot of time! :smiley:

“Input Transformer” doesn’t show up in Cubase Elements. It only appears in Cubase Artist.

In Cubase Elements you can also filter midi channels with an extra plugin and a little bit more work. Here’s an example:
https://www.youtube.com/watch?v=x6eh-fP7yKU
(MidiChannelFilter can be downloaded for free with the MidiKeySwitcher demo at http://www.4drx.com/plugins/midikeyswitcher)

I’ve tried to filter out the unwanted channels but it doesn’t seem to be working. I want to choose Midi Channel A4 on my controller (MPK261) and have it only play Channel 4. I have activated the Modules, and selected local equal/unequal 4…

I don’t know the MPK261, so I have just had a quick look online (but please understand, this is purely “educated guesswork” on my part :wink: )…
Seems that, effectively, it can transmit two sets of MIDI (as if they were separate MIDI ports)… A and B.
Generally, how do you set up the MIDI Input to a MIDI/Instrument track? If you use “All MIDI Inputs”, then both sets of MIDI will arrive at the MIDI track, but (I don’t know this for sure, but, logically…) you should be able to set up the track’s MIDI input to the individual streams from the MPK (the Input dropdown menu… where you also see “All MIDI Inputs”… should show something like MPK261 A, MPK261 B. This way, only the desired “A” or “B” should arrive at the track anyways.

(p.s. I’d be interested to know if this does turn out to be the case :wink: )

same problem with me.
I also not able to find input transformer button.
Maybe it is the problem of version difference or something.