Why does it show CUbase ai 11 in "My Products" in The download assistant?

I uninstalled all my Cubase AI 10 programs and made sure things were updated: The assistant and elicenser. I then wanted to download CUbase ai 10 again. Then under “my products” it said Cubase ai11. I read somewhere that there was a free upgrade. However I cannot get the activation code. I did about everything before writing here. Even restarted the pc.

So now I am stuck and in my elicenser it says only Cubase ai 10. hmmm. Feel tricked to download version 11. What to do now and can I get that version 11 activation key and how? I already wrote Steinberg but the last time I did I never got any answer, so here we go in the forum.


Steinberg Download Assistant is not always right.

Start eLCC and trigger Maintenance, to make sure, you will see the very latest license, you really have. Then, the license, you can see in the eLCC, is the right one.

Download Assistant is a broken tool anyway, and needs a lot of work.
It shows for me WaveLab 11 while I know for a fact that I only have version 9. Never tried to download it though. See, maybe it will work for you. :wink:

You can always download version 10 from the “Cubase” section of downloader.

Yes i did the maintenance like 10 times. My license is for Cubase ai 10. I think I saw somewhere that they allowed some to upgrade for free, maybe when version 12 is released. But I just skimmed the text.

Yes I feel I regret to have downloaded Cubase ai 11 although it said that was “MY PRODUCT”.

You got upgrade for free. Check your emails.

See this post:

Let’s see, let me find out. A few days ago they sent me from Steinberg a free update email for Cubase elemets, etc. I thought it was a gift from Steinberg for those who have Pro. Anyway, I installed it and it works. it’s all on my account besides Cubase Ai Le, but I can’t activate it. so is it forever ?? How can it be activated in my account, or is it no longer needed? also it only works with the dongle. a bit confusing, but it works. It is good for me to help a friend who has elements.

Everything is allright now. Thanks for Your help! :blush: The funny thing is that my old error message still remains even after the installation of Cubase ai 11. Only the download assistant and the Elicenser I only upgraded and did not uninstall. I asked Support about this.

Look for it in the Library Manager and remove it.

Yes I actually had found out this by reading this Error message: Some content could not be loaded… Missing/expired (trial) licenses – Steinberg Support
and gone into the library which was not on my desktop but somewhere in the startmenu. All the other files or folders are on the desktop.

SO I guess I should delete this VST preset FLux thing which is of an older date: ALthough I thought I had uninstalled everything? I have had it from earlier, probably since the ai 9,5 version. Or should I upgrade it? I think if it is not in the list of programs/products under the Cubase ai 11, it probably means I should delete it.

One other question: DO You guys place all the programdata on your Operative system Disk c: or on an alternative disk d:? I have a rather small SSD harddisk but a one tetrabyte big D: drive, and would like to keep the C: as empty as possible. Or would placing some Steinberg data or apps affect the recording quality or speed, therefore delay etc? THe programs I assume ought to be on c: or ?


In the Steinberg Library Manager, you can move all libraries to an external drive, what is recommended in case of small SSD system drive.

Thanks, will do. :+1: SO you mean like files, not Programs but programdata such as wav and midi files etc? Well when I look at the library manager, I think all those folders can be moved so. I don’t know what those folders contain, if programs or appdata. BUt it may indicate that moving those is ok?


Exactly, I mean the sound libraries, which are allowed to go to the external drive.


Did you move the files within the Steinberg Library Manager, please?

Hi Martin. I moved the question into “Errors when moving sound libraries” and solved it with Steve. It took a while but I think it is ok now. Sorry about the duplicate. I forgot to delete it because I immeditately got to trouble shoot so got into that. So the question there is what I posted and you responded to.

1 Like