Why does Render in Place render ALL tracks in a folder?

I have only selected one event but when I render in place it bounces blank audio files for all tracks in the folder that the original event is in.

So if I have 12 tracks in a folder it will print and create 12 new audio tracks and files even if I only selected one event under that folder.

Any thoughts?

Thank you!

Hi,

There are 2 principles of Render In Place.

  1. If you have any event selected, only this event (these events) will be rendered.
  2. If you have no event selected, the whole actually selected track will be rendered.

Principle 1 has heigher priority, of course.

Could you describe your current selection, please? Do you have the event selected, and on the “track level”, do you have the “superior folder track” selected? Or is it different?

It does seem to be broken indeed. I haven’t tried this with folders but I see it all the time with VST-instruments that have several outputs. For example, in Kontakt, if you have 16 outputs activated, you’ll get 16 audio tracks even if you just select 1 event on 1 track (15 of those will be blank).

Additional issue (which is already in the database, BTW) is that it renders any muted parts as well, thus making them audible.

Has ben reported, this changed in 8.20 and no news as to wether they will change it back to a usable situation. Workaround is to render using last 2 options (rendering the sends or sends and mix ) sorry not at my rig now. That will render individual selected outputs without rendering them all, but I have found this to be buggy , sometimes rendering outputs incorrectly etc. Please SB fix this.

RIP certainly needs improving in this respect - it should only render the selected parts.

Please FIX this ! it is now CBP 9.5 2018 and NO fix, I select 1 track and get every out put on a Multi instrument…useless

and still happening for me.
3 Tracks from a VST rendered = 9 tracks. 3 With the audio and the other 6 with nothing.

They will tell you that cubase has now way to know what output has data, so they have to render all of them.

I suppose that makes sense, but I think something could be done to fix that.

Hi,

You are right. The internal instrument routing is a blackbox for Cubase.

You sent some MIDI data from Cubase to the Instrument. The instrument make some internal routing to a specific Audio Return Channel (doesn’t inform Cubase). Therefore when you Render in Place, Cubase renders all Audio Return Channels of the instrument, to make sure, the signal is at one of them.

What’s amazing to me is the fact that this was raised so long ago… allllllllllllllllllllllllllllllllllllllllllllllllllllllllll those new features they’ve added and THIS is still happening…lol

Hi,

I’m just wondering, if you have any technical solution for this. I have only a manual one. So the user would need to setup manually, what Audio Return Channel has been used for this MIDI track in the plug-in. Don’t forget, you could route it to multiple outputs in the plug-in.

Don’t forget, please, the plug-in is a black-box for Cubase from this point of view. Even if Steinberg would improve/update its VST standard to get this information from the plug-in, only very few developers would follow. You can see how little developers is using VST3 today (lots of developers are still using VST2). And VST3 is on the market for quite some time, already. So this wouldn’t help neither.

So, I’m just wondering, if you would have any idea…