Why Dorico doesn't hide staves after option is set

Hi all. Any ideas why Dorico2 does not hide the S.A. part? The option is set to All Systems and none is selected from “Players excluded from Hide Empty Staves”.

It seems there is something written in those measures, because even the Multimeasure Rest does not appear in part layout (although it appears in some other measures). But there is nothing to erase there and I do not know what could be causing this behavior.

Perhaps your gradual dynamic at the end of the top stage on the first system? You could try shortening it slightly to make sure it’s not stretching into the next bar, at least semantically if not visually.

Are all signposts selected for display?

Is it an XML import? There may be an explicit clef.

I managed to resolve it. Because I realized Dorico where interpreting something as written in those measures, I just put the cursor at the end of the last measure and hit Backspace. It didn’t work in Voice 1, but worked in Voice 2.

Thank you dankreider, but none of that was the problem.

I’ve been seeing this behavior quite a bit as well. The solution I’ve found, and this is more of a workaround than a solution, is to marquee select the empty bars (that should be hidden) and press delete. As if by magic, this will make that section of that staff ‘hidden’ (if it is in a system that allows it to be.)

I too have have deleted the contents of bars and been left with totally empty bars, with no whole rests, just blank. I know this is layout option( hide rests in empty bars), but this is not a selected option in my case. These empty bars (with no rests) typically become problematic later when it comes to ‘hide empty staves’ and, in my experience, ‘slash regions’ because the handles of a slash region over these types of bars will not show up. I typically have to delete slash region and re-apply it to get the handles back. I can’t speculate what causes these mysterious blank measures.

billscores, your problem is not what filipedfs is describing - just look at the image in the original post.

If you have bars that show no rests whatsoever, and you don’t have that layout option set, then the chances are you’ve used “Remove Rests” at some point, then deleted some of the music surrounding the rests that you removed. What “Remove Rests” actually does is it sets an “ends voice” property at the beginning of the selection, and a “starts voice” property at the end of the selection. If you delete the note or rest that contains either of these properties, the voice can disappear, leaving you with a situation where there’s nothing at all in the bar(s). The solution is to find the last thing (note/rest) before the void space, select that thing, and unflick the “ends voice” property. If that doesn’t work, skip to the end of the void space and select the first thing (note/rest) and unflick the “starts voice” property.

Sorry, I read the title and the post. The image is different than what I’m experiencing.

I’m sure you’re right. I was not aware that I could accidentally delete an invisible ‘starts voice’ or ‘ends voice’ indicator. I use remove rests from time to time, but only when ‘starts voice’ or ‘end voice’ isn’t removing rests for me. Thanks for clearing up this mystery for me. Didn’t mean to hijack your post, filipedfs.