Why is there no headphone entry

in the OUTPuT Audiodevice menu?
I never get it started to hear Dorico via headphones. Just always the “Internal” solution.

Are you using your default computer output or a sound card?

If it’s your default / in-built sound card, computers naturally mute speakers when headphones are plugged in and route the audio there, no special Dorico options required.

If it’s an audio interface, typically the phono jack has it’s own controls that duplicate the main outs and don’t have to be “selected” as the output, they simply have to be turned up.

Hello, I am just using the internal output while I am in the train… but I really never get it work. It still hearable in the whole track ( ;)) ) though headphones are plugged in…in logic it works automatically to you can choose what you need, but in Dorico it doesn’t. Happened exactly like that 3 hours ago :((

On my M1 macbook air I have to adjust the device settings within Dorico pretty much every day when I plug in the headphones. In the settings there are boxes where you can check speakers or headphones. That seems to take care of it.

My experience is that Dorico remembers whichever output was last used, regardless of the automatic switch of plugging in headphones. I can reset it by plugging and unplugging them. I don’t know why this works, live, when Dorico doesn’t read the current output device on launch. But it works consistently for me.

No that doesn’t work here…it is a bit over complicated in my opinion how much the process is hidden, like about 10 click to change it. Would be better to have popover asking “You want to change to…?” Like in Logic or an easy dialogue like in Ableton.

Maybe in a further version…

Thank you both

You might find it preferable to set up an aggregate device in Audio MIDI Setup and tell Dorico to use that device, relying on the aggregate device itself to handle switching between headphones and internal speakers.