whyyyy. midi keyboard suddenly doesn't work in cubase

if anyone can suss this out, mannnn, i would be so happy

so its windows 10, latest cubase 9 pro, and the midi keyboard is an acorn masterkey 61. it has always worked in cubase then randomly doesn’t anymore.

ive done the following

reset the keyboard, restarted the computer/the keyboards drivers, factory reset the keyboard, used different usb3 ports on pc, run off a usb adapter, and powered adapter, checked its updated the driver, re installed cubase… like literally everything. even tried it on another computer… and guess what it works fine. cubase and windows see it, its activated in midi options, and other midi devices work with the computer.

quick video to show: https://www.youtube.com/watch?v=_KkXwmoKils&feature=youtu.be

man, if anyone can get this i offer £5 paypal and thats a genuine offer I know its not much but this is pissing me off so much and would really appreciate a solution else im forced to sell this keyboard. it worked fine for the last few months and works fine on my laptop. so weird.

Have you tried one of these checkboxes in Device Setup?

thankyou for the reply. no i didnt, tried it now, no difference. the main thing is, that this keyboard works on my laptop plug and play and has always worked on the pc its not working on until today. i havnt changed anything and have tried literally everything :frowning:

Its got to be windows messing up somehow (same version of windows on laptop though, 10) i tired the midi-OX program as reccomended on youtube to test midi input data, it wont take data says i need to quit the program to free up space. it will accept the other midi key i have though.

I did a windows backup 1 week ago, might try refresh to that i guess !! sucks.

swapped some usb inputs around on the pc, now it works. literally tried all the usb ports then swapped it with my mouse usb… now it works… lol… sorted!

Have you re-chosen the track input as all midi in or whatever the specific one is for your keyboard>

Regards :sunglasses:

Ok… glad it is sorted. :slight_smile:

Regards :sunglasses:

restart computer and it doesnt work though… haha oh i give up. yes i did. it seems that its the other usb devices maybe messing this up

In any case it seems unrelated to Cubase and more related to your hardware (most likely PC).

might be a windows 10 update problem as someones suggested as the keyboard is old. might be usb 3 with a usb 1 product, a faulty keyboard, a faulty computer… oh god. so many things.

i got the same versions of windows on my laptop and it works with that. i think im just gunna buy a new midi keyboard with midi out, tried and tested! i had problems with the latest m audio ( it was the keyboard itself) this year too. not much luck with midi keyboards this year!! thinking ill get this anyway,

http://www.dv247.com/computer-hardware/behringer-u-control-umx610-61-key-usb-midi-controller-keyboard--71172

just cos it has midi out, and everything I need for the price I want to spend. Ideally I want the latest pro AKAI midi keyboard but that will have to wait for now