Windows 10: audio dropouts on multi-core CPU setups

“28 divided by 2 is…” … 14! 14 what? 14 physical cores. I did this math, thank you. So are we then talking about CPU’s with more than 14 physical cores that have the issue? In another place it was said that the CPU’s with more than 14 logical cores have problems. Which one is it? I am so confused…Anyone could explain this, please?

Thanks for this. I was here to find out why my new monster box was misbehaving, even after muttering all the appropriate runes over it, this pretty much resolved the issue for me. On another topic, my UAD Apollo Quad Firewire is still falling down pretty regularly with my new setup, my Orion 32 HD arrives tomorrow, we’ll see if that works any better.

Didn’t Firewire lost support after Windows 7?

I have one question when reading this thread, please, someone should tell for what projcts more than 14 cores are needed?
Big sample libraries mostly need much RAM and I don’t know how Instruments and effects should be used to have a benefit from so much cpu cores.

I am not joking I really don’t know it, CPU power was not really a problem in my projects and if, I can freeze (I am using a normal non overclocked i7) and also DIVA. (Even with 5 Diva instances, effects, other Instruments, sample libs, … I easily can keep 64 samples latency)

And what I also do not understand, if Cubase uses more than 32 realtime (the limit which MS has setup in Win10) threads for multimedia scheduler then the cpu mostly waits for finishing every thread and the overhead to handle such big amount of threads only waste cpu power.

I do only little programming, but from what I have learned about programming, threads are good, but too much, specially for audio applications have an opposite effect and is more bad for audio performance. So in my opionion, as an non expert, the Limit of 32 is not that bad and I think MS knows pretty well why they setup that Limit.

There’s a big difference for graphics rendering (nonrealtime), here it doesn’t matter when which thread is ready. There as much threads as possible have an positive effect.

You want to use your hardware to the full potential. If this causes dropouts that weren’t there before, then surely it’s not a good idea to put a limit there.

Windows 10, dual Xeon user here.
As expected, absolutely nothing changed after this work-around.
Cubase continues to make life harder with its audio dropouts

This is a heavy one. You have 2X8 core and 2X16 threads. What happens if you disable hyperthreading? If still as bad then this work around will do nothing either. You could limit Cubase to one CPU and see how that works.

If you mean disabling multi-processing in the device setup, it doesn´t make any difference.
I can´t see any perfomance improvement even after disabling hyperthreading in the bios setup.
Working with cubase is a nightmare for me.

Have you tried the audioengine.properties workaround ?

Sure, see my post above.

No I meant limiting cubase to one cpu. In task manager you can set cpu affinity. If you select the first half of all available you are running on one physical cpu. It is stupid fix if it even is a fix but it will help with the diagnose.

Thanks, didn´t know about that. Changed to one core only but this makes things worse. Now I´m getting crackles and more dropouts when I play some notes. I´ve only one instance of a simple piano instrument open.

Depending on if you see 32 cores (with HT) or 16 cores change to running on 16 or 8 cores. One core is to few. And leave multi processing on!

I wanted to chime in and say I’ve been having audio dropouts in Win10 64 bit on Cubase 8 and 9 on both a 4 core (8 logical) single Xeon workstation and on my new 8 core (16 logical) i7 6900K. I bought the new machine and upgraded to 9 to get around the random dropouts but to no avail. I’ve tried dropping the CPU’s to 14 in BIOS (which I’ve confirmed a few different ways) and using the audioengine.properties workaround. I have ASIO guard off, it’s set to background services, all Intel speed step, C-states, and power saving features are off, no extra audio devices, all drivers up to date, etc. I tried switching video cards today and busted my soft e-licenser somehow.

I’m tracking a full band on Wednesday and we’ll see if I get through it or not. I’m on a monster machine and still getting dropouts that stop recording. My Passmark benchmark ratings of my machine vs every machine in it’s database: CPU: 99th percentile, Disk Mark: 99th percentile, Memory Mark: 93rd percentile. Exporting projects on my new machine is no faster than my old Xeon machine. It’s really frustrating.

I’ve wasted so much time and money on this I’m about to jump ship after roughly 20 years of Cubase. I’m still hoping for a stability release or some workaround so I can focus on recording and mixing again. I record with every VST disabled and huge latencies and I’m afraid to touch the mouse like it’s 1998 again. WHAT IS GOING ON???

Best of luck everyone!
Mat

Do you use, by chance, Ewql Spaces?

I have a Xeon 12 cores/ 24 threads, I worked today the whole day watching the Asio meter and no problem. Stable and no spikes, without any workarounds implemented. I usually don’t care about the asio meter because I render offline (not real time). I have a huge template with lots of VEPro instances both on the DAW computer and on 2 other slave PCs. However, once I add ewql Spaces, things go hectic; the ASIO meter starts to jump up and down like crazy. I try to avoid using Spaces (I run lots of other reverbs) but sometimes I just have to, before I render.

Maybe I am not pushing it hard enough?..I will do more tests tomorrow, watching the ASIO meter.

I’m running an Athlon 2.6GHz with 4 cores with 16GB and Win10 and I continually get spikes. It’s very annoying but I’ve come to accept it. Guess I’d rather deal with this than to go back to Sonar but there may come a day when enough is enough.

JP

Has anyone else tried this simple fix? - really helped on my system.

https://www.steinberg.net/forums/viewtopic.php?f=226&t=97152%20-%20p537505

I have audio dropouts on basic 11 wav tracks played at once. Is that an issue for me?

Make sure you have a proper professional audio driver selected - not the default one.

Will the audioengine.properties file work on Cubase 8 systems?

Is an OS level update expected? Seems like this would affect all DAWs, no?

Also, I don’t understand what I’m looking for when running the mmcss-test file. I run it, and I get this:

starting 128 threads
threads with MMCSS priority: 32
threads failed to set MMCSS priority: 96
Press any key to continue . . .

What does this tell me?