WL 12 creates new file with similar name, even if I chose replace...?

I open an audiofile and want to save it after some kind of edit.
I chose replace and it still creates a new audiofile with the exact same name.

Why and how can I stop this?

You just need to use the “Save” command.
However, if you work on encoded files, like mp3, you need to re-encode them with parameters you have to choose.

image

Exactly what I do since over 20 years.
That’s why I wonder what’s happening in v12…
M1 Mac, latest Monterey.

“Save” is maybe the most common function; if this was not working, this would be known for long :slightly_smiling_face:
Please describe more precisely what you are doing because your original description is a bit vague.

As I wrote before, this never happened in over 20 years of using Wavelab and still doesn’t happen in v11.
In detail:
I open a masterfile rendered in Reaper.
Edit silence at the beginning and the end.
Control + s and get the pop up of how I want to save it, which I shouldn’t get at all, btw.
I chose “replace” and it saves a new file with exactly the same name and leaves me with 2 files.
If I edit the new file again, it behaves as usual.
If this is not a bug, let me know how stop it, please.

Do you see a green corner on that file? If yes, that means this is not a PCM file but an encoded file. And that would explain the behavior.

image

I already told you twice that I use Wavelab since over 20 years and that v11 isn´t showing that behaviour with the same files.
So it would be kind if you wouldn´t treat me like a 12 year old kid, good sir…

I assume it has something to do with the new filesystem.
I´ll try a few adjustments and see what happens…

I am just trying to help.

Maybe directly call the menu (“Save”), instead of using the shortcut (in case of a shortcut problem).

1 Like

If I use Control + S and I am playing a file it stops. This never used to happen. I think somewhere in my computer I have a shortcut that is causing this external to WL. I am still trying to find out what “shortcut” is causing this. Sounds like the OP is having the same/different problem with the shortcut.

I know - just have a little more faith in my expertise ;-)…

Use the menu and do not use the shortcut, to see if the make a difference.

Also, this (old) setting can make a difference when saving file, in terms of UI responsiveness.

image

I´ve tried to use save from the menu as well, of course.

After some more fiddling around, I found out that it´s not happening all the time.
It seems to have a relation to the file-size.

I always render in 96k and the last masters have been pretty long, too.
Today I opened a short streaming edit and it saved it as expected.
I also checked the “save as standard” box for wav. default and now it doesn´t create a new file even if I still don´t know, why “save” in some cases results in “save as”…