WL Elements 10.0.30 patch causing CD/DVD drive issues

When applying the WL 10.0.30 patch to v10.0.20 the CD/DVD drive produces an error and is unusable, I have tried re-building Windows 10 but get the same issue, I also uninstalled iTunes and PowerDVD 20 which use the CD/DVD drive but when applying the patch after reboot D I get the same error in the device manager “Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)”
Steinberg suggested I remove the GEARAspi driver then try the patch, but this also failed to remove the error so provided the good Steinberg developer team with an msinfo32 report which again did not assist them in recreating the issue or identifying what is causing the patch to break the CD/DVD driver!

I finally tried a second full re-build of Windows and all my apps including the Steinberg suite but not any software that makes use of the CD or DVD drive (such as iTunes etc) and still get the error only when I apply this patch

Has anyone else has this issue please?

Did you try these tools?
http://www.gearsoftware.com/downloads.php?dir=freebies/

Hi Yes I did as was recommended by Steinberg, but this still did not help so is suggests there is some other bug in the patch causing the issue as I used the tool to uninstall the Gear driver then apolied the patch but stiil got the same error

Can you show a picture of the message you get, so that I see if this is a WaveLab or a Windows message?

my cd/dvd drive is also “gone”, on my desktop computer. if i read this thread, it maybe related to 10.0.3, i shall look into it. didn’t troubleshoot yet, the first thing i will try, is the bios, if it shows up. (cd/dvd drives i have had, i had never a long lifetime, so i thought, again broken.)

i have the same message in device manager:

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)
the drive is present in the bios, so it works, from the bios. not from windows 10…

Maybe try this:
https://appuals.com/how-to-fix-code-19-cannot-start-this-hardware-device-error-on-windows-7-8-and-10/

I don’t know if this is the same problem. When I tried to import from CD or create a montage to CD there was no optical drive available.

What I did to fix this was:-

  1. Remove Wavelab with revo uninstaller.

  2. Did a custom clean and registry scan/fix with ccleaner.

  3. Extracted both Wavelab 10 Installer and Updater to separate folders.

  4. Copied WaveLab_Elements_10_0.msi from WaveLab_Elements_10.0.30_Update_win\WaveLab Elements 10.0 Update
    to WaveLab_Elements_10.0.20_Installer_win\WaveLab Elements 10.0\Additional Content\Installer.

  5. Finally I ran Setup.exe in WaveLab_Elements_10.0.20_Installer_win\WaveLab Elements 10.0

And voila my optical drive was back.

hope this helps :question:

Thanks but can you explain step 4 in more details?

I’m not certain what you need to know?

I used powerarchiver to extract the files into their own folders by right clicking WaveLab_Elements_10.0.20_Installer_win.exe and selecting extract here and did the same for WaveLab_Elements_10.0.30_Update_win.exe

I then copied the file WaveLab_Elements_10_0.msi from the folder \WaveLab Elements 10.0 Update\ to \WaveLab Elements 10.0\Additional Content\Installer

And then ran setup.exe in \WaveLab Elements 10.0\

as explained above, it seems that wavelab pro 10.0.30 also causes this issue. i didn’t troubleshoot it, i am tired of troubleshooting, to many bug reports… (not for wavelabe, only this one…).

EDIT: sys specs in signature…

it also brakes the mounting of iso’s (wanted to install a library from komplete 11 ultimate; failed).

i shall try the registry hack, but my guess is: it happened after wavelab pro 10.0.30, nothing else (a windows update???), can cause this. i think…

Hi,

please try also following Work Around:
https://helpcenter.steinberg.de/hc/en-us/articles/206632910-Updating-or-uninstalling-removes-optical-drives-from-My-Computer

Thanx and cheers
Kay

Unfortunately with WL Pro 10.0.50 it’s absolutely the same thing. After using the full installer for version 10.0.40 the CD drive is available in WL. Then I install the patch for version 10.0.50. No CD drive available, error 19. Delete UpperFilters in the registry and restart: CD drive working normally, but does not show up in WL. There seems to be a bug for ages, and I hope it will be fixable one day.