WL Elements & Generic low latency ASIO Driver


I installed yesterday at first Wavelab 8 LE & then upgraded to Wavelab 9 Elements.

What does wonder me and I hope someone can help out is the following.

I own several Programs (Cubase Pro 8, Reaper etc. beside Superior Drummer and other VSTIs)
Each of those programs allow me to choose any of the installed ASIO Drivers on my W7-64 System.

Except Wavelab (LE 8 as well as Elements 9) … It does not show up the Steinberg Generic Low Latency ASIO Driver, but all other.

I like this Driver very much to work with in many cases and would like to use this in Wavelab also.

Why is (Steinbergs) Wavelab not able to choose (Steinbergs) Cubase’ provided General Low Latency ASIO Driver. :laughing:

For me this is strange, because all -really all - other Applications can work with this one ?

Thanks for hints or making clear, why especially this Driver does not work for Wavelab.

Does seem odd. Strange no one’s asked before.

Yepp - I googled for this and searched the Forum. All I found was related to cubase. Of course I can use the ASIO4All Driver, but it seems to me the Steinberg Driver is a bit more stable.

So at least if someone can confirm it does/does not work - maybe it is a issue of W7 64. I really have no idea.
So please, if someone can use the Steinberg Generic ASIO Driver with wavelab, it would be interesting to hear which Version of OS.

Thank you

The ASIO DirectX Full Duplex Driver isn’t available in Wavelab either, like it is in Cubase. I don’t think I’ve seen either of those in Wavelab going back to Wavelab 4. Maybe they were considered problematic or unnecessary, and were eliminated somehow, but I’m just guessing.

What is your audio device that has no ASIO driver? (hence requires the Generic Low Latency ASIO Driver or ASIO4All)

Hi Bob & Philippe,
thanks for your inputs.
I am not talking about the old cubase direct x full duplex asio driver but about the actual Generic Low Latency ASIO Driver that came with Cubase Pro 8.5. I have also other ASIO Drivers in my System (f.e. Reasons Balance & Yamaha s Driver fir my UR824) These I can use with wavelab. But that is not my intention.

In normal cases i sit at my computer only using the internal HD Sound Device. That is more then convenient for listening/mixing tasks. For these cases I use the Generic Low Latency ASIO Driver from Cubase. This works with
Cubase, Reaper, Sonar, Reason, Toontrack Solo & so on.
But it works NOT with wavelab.

THAT is my problem. It is no solution to use my dedicated ASIO Hardware, of course this works,
but it is often overkill in my case. And the ASIO4All, that works also is not as stable as the Steinberg Cubase Driver (again, this is NOT the old Direct X Cubase Driver, it is the actual one for Cubase Pro 8.5)

So I like to know why Wavelab does not recognize and offer this driver in the drop down list, when all other applications do. I really see no reason why Wavelab should not be able to work with Generic Low Latency ASIO driver provided with cubase.

The only cases when I use my Audio Hardware is when I record. It is not a fix installation but a installation on demand.

Thank you.


I think it has to do with “Generic Low Latency ASIO”

“Low Latency” isn’t really needed in WL, you like to have
headroom for plugin’s to be able to process audio latency wise.
PG will give an explanation why with drivers but I think this is what it’s about “buffert’s” “latency”.

regards S-EH

Pardon, I guess I did not translate your answer correct the first time…

You mean , the ASIO DirectX Full Duplex Driver does not work also, right ?

That is interesting.

I start to guess it is either simply a bug of Wavelab since Version ??? But it is very very strange that products out of the same forge does not work together :slight_smile: For what reason ever the Steinberg Generic Drivers are disabled in Wavelab.

Maybe they work in the full Wavelab Version ? If not and if noone else can confirm they work I guess I will make a ticket at Customer Service after some days watching the replies in this thread .

Right. I was just pointing out that the DirectX driver doesn’t appear in Wavelab either, although it does appear in Cubase. Which led me to question whether the DirectX and Generic Low Latency drivers were possibly intentionally excluded from Wavelab long ago for reliability or usability. I can’t go back that far in Wavelab forum messages, but I do find more recent posts regarding DirectX driver issues in Cubase.

No they don’t work in the Wavelab full versions either. I’ve only had full versions, going back to Wavelab 4. And like I said, I don’t remember ever seeing the Generic Low Latency or DirectX available in Wavelab. At least back to Wavelab 6, and I think, to Wavelab 4.

Sorry, it looks like I’m wrong. I just checked Wavelab 6 on Windows 7 and the Generic Low Latency driver is there. Sorry, I never noticed that before. So I guess it’s only been gone since Wavelab 7. I don’t see it in Wavelab 7 or later.

Thank you very much, Bob. This helps a lot to figure out the details.
It was very nice from you to figure out so exactly, which Versions worked and which not. So it is obvious it is not a problem of OS or my condiguration. Thank you again :slight_smile:

After this it seems really to be an (intended?) issue from Wavelab 7 to 8. It would be nice, if a member from the Steinberg Team that should have insight to the technical details could clear up why it does not work that way with Wavelab any longer. Cubase 8 works very fine with this driver, so I guess the Steiberg Team knows why. Or is it simly a bug ?

This is not a bug. The “generic” driver in WaveLab is the MME driver. Did you try it?
However, it will be considered to reintroduce this generic ASIO driver.

Of course I tried the MME Driver. But I like to use the Steinberg Asio Driver as I use this in all my other Application. It does not make sense to install ASIO4All when I have a ASIO Driver already. And I prefer to use ASIO then MME in Wavelab. So please make the ASIO Steinberg Driver available again in Wavelab.

Thank you for considering and your reply.

Kind regards