WL in 44.1KHz makes my entire 48KHz-system crash

When I make a CD-montage @ 44.1KHz in Wavelab, while my entire studio runs @ 48KHz, and when I start playing my montage without switching on Wavelab’s resampling function to 48KHz in the Master Section, it makes my Wavelab responseless in the first place and the infamous Mac spinning beachball appears in the second place.
Wavelab won’t play and stays responseless and I have to “force quit” it (I am on Mac)…but the not-so-funny-thing is that, when I look in my Activity Monitor, my “Core Audio” shows a “%CPU” of more than 100% and acts responseless too!
Even restarting my Mac doesn’t work and I have to force shut-down it by holding it’s power button for +5 seconds…

Is this an issue from Wavelab or is this a driver issue from my audio hardware?
I work with an aggregate audio-device from a Metric Halo 2882 and a Metric Halo ULN-8.

Thanks for any help!
Niek/ Amsterdam.


Sounds like a clocking or resampling issue
like 44.1 or 48 kHz the audio system can’t decide which leg to stand on.
I really think this is digital audio in a nutshell and WaveLab will never
sample rate convert by itself the user have to tell WL to do it.

PG will tell more I think…

regards S-EH

Thanks S-EH,
I am afraid you’re right about the (not-)resampling-issue.
Wave lab does respond as expected when I don’t forget to switch on the resampling function in the Master Section.

@ PG:
is there an option to start Wavelab with the resampling-function always switched on?
That would help me a lot I think.

On the other hand; when I work with a DAW (Pro Tools, Logic, Mixbus or Nuendo) in another samplerate than my studio’s clock (=48KHz), the DAW just plays the audio in another pitch and/or with ongoing errors…it doesn’t make my complete system unresponsive…and Wavelab does…why?
Niek/ Amsterdam.

Try this

Preferences > VST Audio Connections >
Preferred Sample Rate set to 48 kHz

in Master Sections
Resampling set to 44 100 Hz
save as a Master Section Presets
choose what you need to save

hope it helps

regards S-EH

I already got that pref set to 48KHz…
It doesn’t switch on the resampler by default, one needs to switch it on manually every time one starts working with Wavelab…

I think, though, that a master section preset will do, but that takes the same users-effort as “switching on the resampler”.

Thanks anyway!

In my case (I also regularly work with resampler for my audio interface) the last state of the resampler is remembered, but maybe it’s different on Windows 10…

Even when I save my Master Section settings as a preset into my montage Wavelab won’t remember the resampler settings unfortunately…
Maybe I’ve been overlooking something again?

Thanks for all the help.
Niek/ Amsterdam.

Are you using WaveLab 9.0.20? A bug was solved in 9.0.20, in this domain.

Certainly I am.
I think the previous verslons of Wavelab9 felt more stable when playing audio in a different samplerate than my system, but that’s just a feeling…
Thanks in advance for your help…


You this setting, if you want it to be remembered at next launch:
WaveLab currently does not restore the “resampling for playback” option (I will try to change this in 9.0.30)

I have a similar problem - that Wavelab hangs when I switch to a project with another samplerate (typically 96kHz insted of either 44,1 or 48). It is as if Wavelab doesn’t “send the information” to my TC interface “telling it to change samplerate”. Other audio-programs seem to operate different, haven’t encountered the same issues with them. Moreover I can’t remember having this issue with WL 8. I wonder if something was changed regarding this in WL 9. I think this is the only issue I have found not working as expected, hope something can be done to change it.


Locate the following file:
Windows 9
C:\Users[UserName]\AppData\Roaming\Steinberg\WaveLab Pro 9\Startup.ini
/Users/YourName/Library/Preferences/WaveLab Pro 9/Startup.plist

Then open it and add this entry:


On Windows, this is easy: this is a text file.

On the Mac, you need to right click in the plist editor, and select “Add Row”

Then You need to set “SampleRateAction” as variable name. And then select “Number” as Type. Then 1 as value.

Does that help?
If not, better rremove that option.


Thanks I will try that!


Damn’ I thought it worked, but it was actually just because I had the resampler active - so no luck there, I removed it again :unamused:

Are there other things to try out?


Philippe, I’m afraid I thanked you too early - see above.


Do you really have another ASIO application, installed on the same computer as WaveLab 9, that can change the sample rate of the TC device?

Yes, but I’ve just discovered an interesting thing: Wavelab can too, if one toggles the resampler on and off :smiley:

I have a project in 96kHz and play it back through the resampler in 44,1. If I disengage the resampler, after a few seconds the TC interface adjust change playback to 96. It even works during playback, though the sound pauses for a few seconds. Maybe that can help solving the issue (without using the resampler).


So, what does not work?..

…it doesn’t work when I jump between two projects using different samplerates, without the resampler engaged.


Really strange, because that is the same procedure, internally.
I assume you use 9.0.20, right?