WL10 on macbook: "the audio device (96 000Hz) rejected the sample rate change"

I’m trying to get some editing done on my 2017 MacBook Pro. I usually use a better interface, but I have nothing with me but the computer & headphones today.

I have a batch of 24/96 files to work on, and I imported them into a new WL10 project which is set for 24/96. But whenever I attempt playback, I get a popup that says “the audio device (96 000Hz) rejected the sample rate change”. Note: I can resample to 48Khz in the master section and it works.

The files are 24/96:

The project is set as 24/96:

Logic can playback the same 24/96 audio files, and the finder ‘preview’ can play them. I haven’t found any evidence whether the builtin audio in this computer can handle rates above 48, but I would certainly think so(!!). If not, then Logic and Preview must be silently resampling to 48.

Am I doing something wrong?


I don’t think you’re doing something wrong, but you may be right about the other playback modes silently downsampling for playback. I don’t know anything Mac, but can you see and adjust audio settings anywhere from the OS side?

Did you try to open the control panel of the driver that is selected in the WaveLab audio connections dialog?

Coreaudio is a multiclient driver so if you have another program open like a web browser, played back a video at 48k etc… the system sometimes “hogs” the driver and blocks other programs from changing sample rate.
Close all other apps and Open Audio-Midi Setup in utilities and manually change the sample rate to 96k on the Built-In audio tab

Yes, but no luck at the time.

I’m docked to my normal Thunderbolt dock now, and 96K is working both with the dock’s audio interface and with the internal audio interface. So your theory must be right (or at least truthy :wink: ), regarding something having the sample rate locked.

Weird that Logic worked, but I’m not gonna sweat it.

Thanks for the replies!