WL12 won't render montage when destination file has been opened and closed

There is an intermittent issue in WL12 where I am getting a message that I can’t render the montage because the file is already opened when the destination file I’m trying to overwrite with a new version has been opened and closed. I was able to work around this in WL11 by opening the destination file (the one I’m trying to overwrite) in a new file group and then closing the group before attempting to render it again, but in WL12 this does not always work, sometimes I still get the error message in which case the only remedy I’ve found is to close and reopen the program. Could this possibly be due to a cache file not always updating when a file has been closed so it thinks it’s still open? Could I delete this cache file manually when I get the error message instead of having to restart WL?

What do you do, in WaveLab,with the file you have rendered? If any part of it is used elsewhere (eg. clipboard or clip), then it remains opened in WaveLab.

Sometimes just having the file opened automatically after rendering then closing it gives the error message when I try to render it again. In this case nothing at all has been done to the opened file except playback. In other cases, the rendered file is placed in another audio montage with the sequence of mastered files. When adjustments are to be made, I close the montage with the sequence so I can re render the montage with the mastering chain. No part of it remains open as far as I can tell. This behavior is not consistent, sometimes it will allow me to render, sometimes I get the error message. If I make a change on the resulting montage with the rendered file and try to close it without saving, then save the file, this generally will allow me to render the file without the error message which is why I suspect it’s an issue with the cache of opened files not updating always when they are closed. Thanks for your help.

Following up on this, can you please check it out and include a fix on the next update? The resulting rendered file is not open and nothing has been copied to the clipboard or used in another open montage, but I still sometimes get the error message that it cannot be rendered due to being already opened. Restarting each time this happens is a waste of time. If there’s another way to work around this by deleting cache files please let me know.

There is no such problem I can reproduce. If you can, make a video with a simple case, from launching WaveLab until the problem happens, so that I can identify a pattern.

Open program → render audio montage → open rendered file in new montage → close montage with rendered file → attempt to render original montage → sometimes there is an error message saying the file is still open which it is not.

If the message happens, this is because the file is open for sure (this does not mean, visible). There must be something additional you do, because I still can’t reproduce this issue with the procedure you describe.

It is intermittent but happens daily and I’m not finding a correlation to any specific actions that cause it. I had this same problem in WL11, but on that version by opening the 2nd montage with the resulting rendered file in a different file group, which I then closed before rendering the original montage, fixed the error message that it was still open. Unfortunately this work around of using a separate file group to open the rendered file and closing the group is not fixing the issue in WL12 and I must restart when it happens. Once I restart it will allow me to render without anything changing. I’m not finding any aspect of the rendered file that is still open or copied to a clipboard in any way when this error message happens.

Is there a cache file for the open montage that then automatically clears once it’s closed or updated? Thanks for your help trying to sort this out. If I can just find a work around to avoid having to restart the program that would be great.

Still no cue. Try to give more details about your procedure and types of files. Plugins can’t be involved in your scenario.

An Audio Montage with one 24/96 WAV file is rendered to a 32 bit float 96k WAV file. This resulting WAV file is placed in another montage with other tracks for sequencing. When I close the second montage with the sequence containing the rendered file and try to render again, Wavelab gives me the message “The following file is already opened in WaveLab. Specify another destination file name.” The resulting montage is not open anywhere in Wavelab. It was opened, but has been closed before attempting to render the source montage. When I restart the program, I get no error message. This is an intermittent occurrence.

What types of files are created when a montage is opened and how does the program know when a montage has been closed? I have auto backup enabled.

Thank you.

Only the associated audio files.

When the montage tab gets closed.
But any associated audio file is only closed if it is not opened or used elsewhere (even a copy of a clip or audio range, causes the related audio file to remain opened).

This should have no side-effect, as a backup is just a file copy.

Please continue to monitor any actions you take that could lead to differences between the two scenarios: the standard one, where closing a montage does not prevent you from re-rendering, and the case where you receive a message about a file still being open.

Thank you. To clarify, no elements of the resultant file are open or copied to the clipboard when this message happens. In version 11, I was able to remedy this for the most part by opening the resulting sequence montage in a new file group, then closing that montage and group before re-rendering. I’m not able to identify any different circumstances when this happens and it is intermittent. The only solution I’ve found is restarting the program, which fixes the problem without me changing anything else.

I’m assuming that closing the program clears the cache of open files as well as the clipboard memory. It may be that somehow there is an element getting copied to the clipboard without it being selected to do so. I’m not using the copy or paste functions at all nor doing any copy and paste editing from or within the second montage with the sequence containing the resulting file. The only editing is heads/tails trim and fades. (the resulting montage is a sequences for a specific release format)

Could loading a plugin chain from a file (using the “load plugin chain” option in the inspector for the montage) cause the plugins loaded into the effect slots to be copied to the clipboard?

Is there a function to clear the clipboard memory or is this a function that could be added? If I could clear the clipboard memory that would either fix the issue or rule the clipboard out as being a possible cause.

This could possibly be related to the copy function issue with the copy option becoming greyed out once something has been copied to the clipboard or that may be an entirely separate issue. I’m mentioning it because both could be involved in the clipboard memory in some way.


There is none, but that could be a good idea indeed.

1 Like