[Workaround] Playbacktemplate missing

After installing Dorico3 on drive D: instead of C:, when loading my saved project, an error message appears stating the playbacktemplate file is missing. This results in being unable to listen to the created track. When exporting as musicxml, and importing into cubase, it seems no instrument data seem to import as well.

Welcome to the forum, musico. Is the missing playback template for NotePerformer, by any chance? If so, please follow the steps in this thread.

Thank you for your welcome and Reply. Unfortunately it’s not NotePerformer, but Dorico 3 itself.
To be more precise I’m referring to the german install file for Dorico 3 Elements ‘Dorico_3_Installer_win.exe’, not using the default install path, but drive D: instead. The error promt translated into english reads something like: This Project is referring to a Playback template playbacktemplate.hsse, which is not installed on this system. Reinstall didn’t help either.

Even if you install Dorico itself on the D: drive, the default playback templates live inside the program folder anyway, so there should be no problem in finding them. Did you definitely also install the “Sounds for Dorico Elements 3” installer from Steinberg Download Assistant? If you open Steinberg Library Manager, do you see e.g. Olympus Choir Micro listed there? If not, you’ve not correctly installed it.

The App package and the Sound Library from Dorico was installed, and can be verified with the Library Manager being on D: as well. Though Cubase 10 was installed already, therefore only the Olympus Choir Micro was effectively installed from the sound library package.
Adding to this, 3 playbacktemplate files are indeed found in the Dorico folder on drive D: - nevertheless regardless of the project, always at 80% of load time, this error message pops up, but successfully loads the project. Only playback will freeze Dorico3. The rest is working normally.

I don’t run Windows myself so I can’t give you chapter and verse on the correct location, but can you check the “playback” folder inside the “Dorico 3” installation folder in Program Files and see that e.g. the “PlaybackTemplateGenerators” folder contains three subfolders, “HSSE”, “HSSE+HSO” and “Silence”?

Verified. Folder structure exists, and contains 2 files HSSE multioutput.pluginstate & playbacktemplategen.xml for HSSE and HSO, just the latter file for Silence.

OK, can you please start a new project with a single player and instrument, then add a few notes and see if you get any sounds loaded? Please then save and zip up that project and attach it here, and also please do Help > Create Diagnostic Report and attach the zip file produced on your desktop as well.

Files removed, as they did not contain valuable info on this topic. See below for workaround solution.

Those log files appear to show that Dorico is able to load the playback templates on start-up with no problem. I’ll need to ask my colleague Paul to take a look at this and provide some more insight.

Just adding the screenshot for the error during load, as well as mentioning when I select the VST-Instrument, e.g. Halion Sonic SE Piano and MIDI-Instrument, e.g. Native Instruments Komplete Audio 6, by hitting ‘Play’, Dorico3 freezes.

I had the same error message in Germann after installing Dorico 3, and no sound or Helion.
I went to the playback template set-up area… (don´t ask me exactly what I did), picked a template and saved it as default.
Problem solved for me…no more error messages since then, and beautifull sound.

Hi Concha, did you change the general settings, or the settings in the playback mode picking a template as default? I will try the same meanwhile Daniel is investigating with Paul on this matter and feedback when I get more details from you to test it.

I‘ve received notification from Steinberg Germany, that this error is reported from several users using only the German release of Dorico, and developers are working on a fix…

Same problem here. When will the problem be fixed by Steinberg Germany? Could I use a non-German version in the mean-time? How do I get one?

Welcome to the forum, matimori. You should find that simply choosing Play > Playback Template to reapply the default playback template will fix the issue for any project that shows this warning message. This problem will be corrected in a future update, but there is no date for this update at present.

I made this work, and the youtube video mentioned in the Dorico forum FAQ: New users start here by Daniel/Paul? helped me: https://www.youtube.com/watch?v=5BcPJd92zqU
In Essence you need to configure your device. Choose between Asio or your external audio hardware. In my case I selected the NI Komplete Audio 6 device. Second, you might need to go into Playback mode and select from the Play menu ‚Apply Default Playback template…‘. The wording in german is quite different, but the order of the menu structure is the same, so you should find it.

Changing the device configuration between asio and your hw device is not a good idea, as Dorico3 might lock-up.

I‘m happy it‘s working now, as Dorico is a wonderful piece of software. Some part is probably by me not watching this video. It could be easier, when you‘d be asked to set your device and select this menu entry for the first start.
Thanks Daniel for all your help and creating Dorico3.

Just to let you know that my English language version of Dorico Elements was giving me the same error message, and eventually stopped allowing me to load instruments at all, but I fixed it by doing as you suggested. Cheers for that.

Welcome to the forum, @Magenta, and I’m glad this helped you.