Workflow At A Loss

I’ve been using Cubase since the early 2000’s and since I’ve upgraded to Cubase 10 Elements I’m at a loss for words because it just doesn’t work right.
I tried Vegas Audio once upon a time and it was pretty good for audio back in the day. I tried Fruity loops which was great for Midi but terrible for audio. I tried logic and could not find any logic in at all. I found Cubase and was amazed that it did everything the other programs could and more. I was talked into buying and using an mbox with protools. What a waste of money that was, the leading studio audio equipment felt anemic compared to Cubase. I love Cubase and have always said to friends that it can do anything you need it to if you’re prepared to get in under the hood, well did up until now. This is the first time my workflow has been disrupted. I love Cubase so much I’m hoping to have an open mind and hopefully hear of some techniques or workarounds to perhaps some bad habits I’ve found myself with.
First I apologise for the story but I hope it gives some context to whomever is programming this beast of a program.

I’m a musician, I play instruments, I hold them while working with Cubase. The right click menu tools is rubbish now. I used to be able to change and edit things with my right hand on the mouse with one button press and a down movement of the mouse. I now find I have to move down and across and down. I know it’s not much but right click down across scissors, cut an audio, right click down across select is absolutely frustrating when it worked well enough.
The other issue is using a keyboard for shortcuts. So I always hated the spacebar for play, spacebar for stop. It’s not so bad but it never returned so I setup my number pad because it’s closest to my mouse. I use (0 Ins) as play, (. Del) as one touch stop and another touch return. The enter is record. Bottom three buttons on the number pad. The .Del is not so efficient as it’s 99% of the time a double tap but I’m used to it after 20ish years. So the problem is for the first time ever when a plugin is in focus the (. Del) button on the number pad has started working as a Delete key. I now have to click on the project window to have my key commands work as they should.
Sorry for the rant and if anyone can help or offer workarounds I’d truly love to hear.

If you are working kinda one-handed & physically constrained you should take a look at Metagrid, especially if you already own an iPad. It lets you have lots of customized buttons that can do anything that can be set to a Key Command, plus some other stuff. It does require some upfront setup effort to arrange things to suit your specific needs. Several threads on here about it.