Workflow Question

Bear with me here; this might be difficult to explain. I’m trying to solve a workflow issue. I’d like the Key Editor display to stop jumping back to the beginning of Part when the Part is selected in the Project Window.

Explanation below:

Say I’m editing MIDI data in the Key Editor for several Parts whose MIDI data is almost identical (Violins 01 and Violins 02, Violas and Celli) I have the Project Window open on one monitor and the Key Editor opened on a second monitor.

I have both Violins 01 and 02 Parts selected in the Project Window, so in the Key Editor I can use the drop down Part list to select either one to work on. So far so good. I understand that workflow.

But now I need to select a third Part (say the Violas which has the same length and start time as the Violins Parts) and do some more editing in the Key Editor.

Now here’s my problem. When I select the new Part, the Key Editor loads up the Viola part, (OK, fine) but the Key Editor’s display also jumps back in time so that the left edge of the screen is at beginning of the Violas clip. This makes me have to manually scroll back to the time/bar/beat/measure I was working at before selecting the new Part.

So, is there a way get the Key Editor time to just stay where it is when I select a new Part from the Project Window? To not jump back in time to the Part’s beginning?

Does that make sense?


Makes perfect sense.

Wow - they still have not fixed this in v7? Unbelievable. I have v7, but have not used it much. This issue is present in v4, v5, and I would assume v6.

You say: “When I select the new Part, the Key Editor loads up the Viola part, (OK, fine)…”

It’s actually not only when you open the Key Ed for the violas - it’s any time you select something in the project window. All you have to do is click on another event, and the Key Ed that is open will go back to the beginning.

The only suggestion I have is maximize the key editor, and use either ctrl+w to close the window to go back to the proj window, and then use a kc to re-open the key ed., or use ctrl + tab to toggle between the key eds, and the proj window, which will leave the cursor in the right place. I know that you aren’t used to working that way, and therefore that might be a PITA, but unless someone else has a better suggestion, that’s about the only way to go about it.


Hi Mahlon.

Have you tried to untick the Preferences->Editing->Link Editors box?


Holy crap! That appears to work!!! Wow - here I was thinking this was an actual issue all this time… :unamused:

don’t do a lot of MIDI here, but do remember ‘tolerating’ (or rather, learning to tolerate) this behaviour/design fault/PITA in the past… Jeff’s right.

So, this should be reposted - but where…? In the Issue Reports (its a bug…!?!) or as a Feature Request (its currently working as designed…?!). Cut the preamble down a bit; just do a simple step-by-step repro - they like that sort of thing. Title:- [ISSUE] Key Editor linking

Damnit! I meant to post this in the Cubase 6 forum. I went back to 6.5 until C7 selected Mixer Channels deselecting MIDI tracks in Project Window is fixed.

Thanks Jeff, Kris, Puma. I don’t know if that option is available in 6.5, but I’ll have a look when I get home. From your posts, I gather it’s not. RIght now at work; can’t find expanations for Preference submenus in the 6.5 manual. Don’t think that made it in.


Ahaaaa. It is there in 6.5. I guess I’ll have to decide, though, between doing what I want above or having the luxury of leaving the Key Ed open with automatic Part switching. Damnit. Doesn’t look like I can have it both ways.

Thanks again for the tips,