Workspaces on OSX: Why is everything only on one monitor?


Please forgive if this has been discussed. Did a couple of searches with little luck.

I have two monitors. I place the mix console on one and the project view on another. I assign that configuration to a workspace. When I try to call up that workspace, BOTH windows end up on the same monitor.

ANY layout I design and save when recalled all ends up on just one monitor.

This has happened under 10.9.5 and 10.10.2.

Not a huge issue; I’ve been dealing with it for a while now. But it is starting to get old.

Since I don’t see a lot about it on the forum, I figure it must be something I’m doing wrong.

Any advice is appreciated.


Sorry, the only help I can give is to say that the workspaces work perfectly here with three displays/screens/monitors. What you do “wrong” I do not know. I just drag the different windows to the desired monitor and save as workspace. I have several workspaces and key commands for them. However when loading a project it will only load up one monitor, main monitor, with only the track section. Then I use the key command for the particular lay out and everything loads correctly and project related.

Thanks. That is exactly what I want to happen, but when I hit the key commands ( or select a workspace from the menu bar), everything stays on one screen.

Has no one else experienced this or heard of a fix?


How does the mac desctop behave. If you put something (like a folder) on monitor 2 and reboot, will the folder still be on monitor 2?

Yes it will…

Hmmm strange. Frankly I have no clue. If you follow the prescribed procedure and re-open and then the windows are on top of eachother on one monitor? Never experienced that during my 10 years With cubase on multiple monitors. Do you have a friend or a retailer where you can try out the same procedure? Or someone you can SKYPE With?

Thanks for the quick response.

To answer your question: I don’t really have someone to confer with. Guitar Center doesn’t have Cubase set up there, and most of my other compadres are running PT or LX.

It’s very bizarre. Thought maybe it has something to do with how mission control preferences are set? I have “Display have separate spaces” unchecked. Is that correct?

I will check but I believe it is the other way around try it out. You do no harm as you can reverse later. If playing With the desktop does not do it I can offer you a Skype sometime during NeXT week. I have my Cubase on a mac but I work (and Write now) on a PC.

That is very kind of you. I’ll give it a go. Thanks!

Maybe if you decide to start Cubase in a certain desktop it might work. You do that by right click on the Cubase icon in the dock and choose settings. Here you can select desktop 1, 2, or whatever.
I always starts sequence apps in the leftmost desktop.