write attributes to file is inconsistent

When I go into the Pool and update the tempo info and then Write Attributes to File it doesn’t always actually do that. I can see in MediaBay that no tempo info has been updated. tried refefresh, save project,etc. works only half the time. bug?

And also the “write to file attributes” in the Media menu seems to do nothing that I can see.

This option does nothing to any selected audio file in the pool.

I checksum the file, set the Tempo, key etc and then click the option to write attributes to the file, checksum the file and it’s the same. Therefore nothing has been written to the file.
I’ve tried wav, flac, broadcast wav… which files did you say you had working?

Cubase Pro 10.5.12 Build 123

We agree. Hopefully somebody that can fix it weighs in.

I have asked this question before and never got an answer. I would also like to know what “Write Attributes to File” actual does. I initially speculated that since WAV files cannot be tagged (unlike AIFF) and Broadcast WAV can be tagged (through JUNK), that the menu item might convert standard WAV into broadcast WAV for later metadata / tagging purposes. Maybe then Media Bay can also write some tags directly into the WAV file, while also doing that in the database. But I am still not sure if that might be the case or what else this menu command does… One would think that changing WAV to Broadcast WAV would alter the file size in some way, so if there is no checksum mismatch, then the mystery remains.

If someone from the DEV team could enlighten us, that would be greatly appreciated… Maybe the developer who came with it in the first place went missing and devs in the new team don’t dare to get rid of it, because they also have no clue what it actually does?